Announcement Announcement Module
No announcement yet.
Questions on spring roo pizza tutorial Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Questions on spring roo pizza tutorial


    1. May I know why the login is accessible, how do you make the user to redirect to login page for every of the pages before he can access the admin pages?
    2. The entities are created manually, let's say I want to model my entities based on MySQL database.
    How do I do that?

  • #2

    I moved this question over to the Roo forum, since it is mostly Roo related.



    • #3
      found that reverse engineer command in roo shell with mysql database
      only the root username and password have access to allow reverse engineer command
      the rest shows access denied @localhost(using password:YES)


      • #4
        I deleted the spring roo project and tried reverse engineer again using root username, now it gives the access denied error again

        I have ticked all the privileges for the MySQL user, I have no idea what's wrong

        Attached Files


        • #5
          We've reverse engineered many MySQL db's without issue. What do the properties in your look like? Does it work in the forward direction, ie using an ORM to persist entities?


          • #6
            ok, i tried to delete and let it download the repository again, now it can reverse engineer

            but i got this error, tried this many times still had this error:
            Caused by org.hibernate.HibernateException:Wrong column type in db.table1 for column col1.Found:timestamp,expected date
            at org.hibernate.mapping.Table.ValidateColumns<Table. java:283>
            at org.hibernate.cfg.Configuration.validateSchema<Con>

            Is reverse engineer unable to reverse engineer a datetime? I tried to convert to datetime in db, then there is another char error, expecting varchar.
            These are the steps i tried to do to reproduce this:

            1.In STS,New->Spring roo Project
            2.In roo shell, jpa setup --database MYSQL --provider HIBERNATE
            3.keyed in database properties
            4. In roo shell, database reverse engineer --schema no-schema required
            5. type web mvc setup, followed by web mvc all --package ~.web
            6. type perform package
            7. Copied the package ProjectRoo-0.1.0.BUILD-SNAPSHOT in target file to Apache Tomcat webapp folder
            8.Rename the folder to ProjectRoo
            9.Run the tomcat application


            • #7
              the error are as follows
              Attachment Attachment

              according to this
              when reverse engineer
              the types do not get convert to the type I want?

              is it possible to resolve this?
              Attached Files
              Last edited by z080236; Jan 17th, 2013, 11:22 PM.


              • #8
                DBRE uses the metadata returned from the MySQL jdbc driver to determine what field types to use, which follows java.sql.Types. Going forward via the ORM is a very different story. Try the --includeNonPortableAttributes attribute on the database reverse engineer command to see if this helps


                • #9
                  wonders why i have to always install jdbc driver

                  doesn't it go to repository when i run

                  addon install id --searchResultId01