Announcement Announcement Module
Collapse
No announcement yet.
No crosscutting model available. Rebuild project Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • No crosscutting model available. Rebuild project

    I'm using STS 3.2.0.MI and Roo spring-roo-1.2.3.RELEASE. I tried to create sample spring MVC as well Spring JSF but for all of projects I've the same issue. Even tried in different machine but couldn't find the root cause for the issue.

    Note:- I did rebuild project from STS Project -> Build Project and also tried Preferences -> click to DISABLE/ENABLE and Reindex now.

    Also tried STS 3.1.x.

    Help is really appreciated.

  • #2
    Did you try and clean the project before you rebuilt it? Also is Spring Aspects Tooling enabled in the project?

    Comment


    • #3
      I did clean the project before rebuilt but not sure how to check Spring Aspects Tooling enabled or not. I'm using STS and how do I verify that

      Comment


      • #4
        if you right-click on the project and choose "Spring Tools" -> "Enable Spring Aspects Tooling" you'll enable JDT weaving (if this wan't enabled already in the prefs, the status of which I assume you already know about) and ensure that the spring-aspects.jar is on your aspect path. You can see and set this manually in the properties of your project under "Aspect J Build": tab "Aspect Path".

        What messages do you have in the markers view related to this project of yours? From what you've written it sounds like the Aspects are not working properly.
        Also ensure your project both have a Maven nature and a Spring nature.

        I recommend that you issue one Roo command at a time and analyze (as well as commit) all relevant files in the project after each step. You will learn much from this. I've noticed that sometimes projects created within STS do not get the proper nature and/or settings and so have to be set manually.
        Last edited by MiB; Jan 14th, 2013, 03:13 PM.

        Comment


        • #5
          whenever I start creating new Spring Roo project I do see under "Markers"
          Java Build Path Problems
          Project 'xxx' is missing required source folder: 'src/test/resources'
          Java Problems (1 item)
          The project was not build since it depends on xxx, which has build path errors

          Once I add the missing src/test/resources manually, I'm able to do refactoring looks like this is the culprit here.

          The question is why Spring Root not creating src/test/resources folder

          Comment


          • #6
            Yes, I also noted this recently. What one do is make a bug report in the Jira. I find the Springsource community more or less excellent in handling bug reports.

            Comment

            Working...
            X