Announcement Announcement Module
Collapse
No announcement yet.
STS autocomplete does not work with Roo generated entities. Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS autocomplete does not work with Roo generated entities.

    I have a strange issue with STS. The autocomplete stopped working for the Roo generated entities. At the same time if I manually type the method from aj file the code compiles fine.

    I made sure that JDT weaving was enabled and reindexed project.

    I even tried downloading a fresh STS and using a fresh workspace and created another ROO project from scratch, but autocomplete that didn't help.

    I am at a loss already - anybody has a clue?

  • #2
    Sample problem - Changing workspace works for a moment

    Originally posted by Vladimir.Fedorov View Post
    I have a strange issue with STS. The autocomplete stopped working for the Roo generated entities. At the same time if I manually type the method from aj file the code compiles fine.

    I made sure that JDT weaving was enabled and reindexed project.

    I even tried downloading a fresh STS and using a fresh workspace and created another ROO project from scratch, but autocomplete that didn't help.

    I am at a loss already - anybody has a clue?

    SAME PROBLEM.
    When I change the my workspace to a new one, autocomplete works again. But if I restart sts, it stop working again. I've tried Mac OS X (Carbon) springsource-tool-suite-2.9.1.RELEASE-e3.7.2-macosx-carbon-installer.dmg
    Mac OS X (Cocoa, 64bit) spring-tool-suite-3.0.0.M3-e4.2-macosx-cocoa-x86_64-installer.dmg
    Mac OS X (Cocoa, 64bit) spring-tool-suite-3.2.0.M2-e4.2.2-macosx-cocoa-x86_64-installer

    None project works. I have no idea how to proceed working. I can't close sts or it stop autocomplete when restart. sts stop recognize methods from *.aj files.

    Comment


    • #3
      Solved

      SOLVED: I've tried restoring java assist default options in 'Windows > Preferences > Java > Editor > Content Assist > Advanced'. But I've not got sucess.
      The problem was in Preferences > Java > Compiler. JDK 1.7 compiler wasn't working. I changed it to 1.6 and starts working again.

      Tks

      Screen shots

      Attachment
      Attachment
      Attached Files
      Last edited by adrianosantos; Feb 6th, 2013, 08:24 AM.

      Comment


      • #4
        MAC OS Software Mac OS X Lion 10.7.5

        Just now I realized that After upgrading my OS to Lion 10.7.5, VM Java 1.7 was removed. Because security problems, java VM isn't native anymore.
        Note if java VM icon exist in your Preferences System, >others. If not, try install java again.
        http://java.com/pt_BR/download/index.jsp






        Originally posted by adrianosantos View Post
        SOLVED: I've tried restoring java assist default options in 'Windows > Preferences > Java > Editor > Content Assist > Advanced'. But I've not got sucess.
        The problem was in Preferences > Java > Compiler. JDK 1.7 compiler wasn't working. I changed it to 1.6 and starts working again.

        Tks

        Screen shots

        Attachment
        Attachment
        Attached Files

        Comment

        Working...
        X