Announcement Announcement Module
Collapse
No announcement yet.
Problem with spring beans schema Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with spring beans schema

    Hi everybody.
    I am experiencing a problem that is very weird (to me, at least)

    I'm building a Roo project with Spring data repository support.
    When I try to add a dependency af a library of my own, in the file applicationContext-jpa.xml I get the error
    HTML Code:
    Referenced file contains errors (jar:file:/home/stefano/.m2/repository/org/springframework/spring-beans/3.1.1.RELEASE/spring-beans-3.1.1.RELEASE.jar!/org/springframework/beans/factory/xml/spring-tool-3.1.xsd).
    I thought there were some conflicts in dependencies, so I excuded all the dependencies of the library project (thay are always available because they are also included in the main project dependencies), but the error remains.
    If I remove the library project from the dependencies of the main project, the error disappears.

    May someone help me to solve this issue?

    Thanks,
    Stefano

  • #2
    I figured it out.
    The library project depended on spring-security-core-3.1.1.RELEASE which depended on other many spring packages (such as core, aop, context, ...) all with the verson 3.0.7.
    Once I excluded all the dependencies of spring-security-core from the library project POM file, the error disappaered.

    Comment

    Working...
    X