Announcement Announcement Module
Collapse
No announcement yet.
problems with Roo 1.2.2 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • problems with Roo 1.2.2

    I'm trying to setup my database to use postgres. I have already been able to access this database using STS Data Explorer without any problems.

    I am using a roo 1.2.2 shell in my STS IDE

    I ran:

    jpa setup --provider HIBERNATE --database POSTGRES --hostname <host> --databaseName <db> --userName <name> --password <pass>

    When I tried to do:

    database reverse engineer --schema <db>

    I get:

    Located add-on that may offer this JDBC driver
    1 found, sorted by rank; T = trusted developer; R = Roo 1.2 compatible
    ID T R DESCRIPTION -------------------------------------------------------------
    01 Y Y 9.1.0.901_0001 Postgres #jdbcdriver...
    --------------------------------------------------------------------------------
    [HINT] use 'addon info id --searchResultId ..' to see details about a search result
    [HINT] use 'addon install id --searchResultId ..' to install a specific search result, or
    [HINT] use 'addon install bundle --bundleSymbolicName TAB' to install a specific add-on version
    JDBC driver not available for 'org.postgresql.Driver'
    roo>

    So I ran

    ddon info id --searchResultId 1
    Name.........: Spring Roo - Wrapping - postgresql-jdbc3
    BSN..........: org.springframework.roo.wrapping.postgresql-jdbc3
    Version......: 9.1.0.901_0001 [available versions: 9.0.801.0001,
    9.1.0.901_0001]
    Roo Version..: 1.2

    But the "database reverse" command is still giving the same error, what am I doing wrong, how do I debug?

    Is the postgress driver which says its valid for 1.2 still valid for 1.2.2?

  • #2
    I had a cut & paste error in previous mail, that should of said I tried to do the install using:

    addon install id --searchResultId 1

    Comment

    Working...
    X