Announcement Announcement Module
Collapse
No announcement yet.
Roo hanging - any suggestions? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Roo hanging - any suggestions?

    I have a Roo project which has started hanging Roo. Do you have any suggestions for a clean up? It will take me a couple of hours to re-scaffold.

    The symptoms include:
    - works fine as an STS project until Roo is opened
    - when Roo shell is opened a couple of lines are emitted to say "updating ..... file", then it hangs
    - the 2 cpu go to 80 to 100% usage
    - closing STS does not kill the Java process that is taking all the resources

    This seems "standard" corrupt eclipse project behaviour except it only happens with Roo

    Tried:
    - ->project->clean
    - -> Maven->update project
    - validating that dbre.xml is clean xml
    - importing into a clean workspace
    - changing to STS 3.0.0
    - clearing the eclipse cache directory

    Environment includes:
    - Ubuntu 12.04 LTS
    - Java 1.7
    - 64 bit

  • #2
    You mentioned dbre. How may entities are there in your system? Did you create the project in STS or standalone Roo?

    Comment


    • #3
      - About 45 entities in app
      - use Roo within STS mainly

      If I had to say what made it start happening I would think running a command "database reverse engineer" which was going to add another 25 tables.

      I am currently re-scafolding and it seems fine with the 70 tables. Did that from command line rather than from withing STS after reading

      http://stackoverflow.com/questions/9...687238_9883520

      Took the advice to set 'Refresh using native hooks or polling' option in your eclipse workspace preferences" but that did not make a difference.

      Incremental dbre is not working for me, as described in comments here https://jira.springsource.org/browse/ROO-3231, but it never has.

      Prob not relevant, but just in case, also not working is Filters->Hide generated Spring Roo ITDS - they show no matter what the setting.

      I would be happy to send the project if you wanted it.
      Last edited by greg.soulsby; Aug 31st, 2012, 01:07 AM. Reason: poor english

      Comment


      • #4
        Hi,

        I'm not even sure if I'm able to resolve it and the reasoning I'm going to give is correct, but here's my take. I'm using STS 3.0.0 on a MacBook with LION. I've added two different users through which I access the installed STS. BTW I installed STS from 64-bit .DMG file into the location /Users/Shared/springsource. I chose this directory as I wanted this STS folder/application to be usable by both the users. Everything worked fine for around a month till I started exploring ROO.

        After beginning to explore ROO and creating my first custom learning project, the dreaded message "Please wait while ROO shell is fully initialized" started coming and would never go away. I checked STS error logs and everything was fine there.

        That day onwards, the other user through which I used to access STS started getting an error while trying to start STS, the exact text I don't remember. But somehow that prompted me to duplicate the STS installation.

        This time around, I installed STS within the HOME directory of the user. From that point onwards, ROO has been starting without issues. For the other user, I had to make him the owner of the folder /Users/Shared/springsource and since then the problem disappeared for this user as well and ROO shell started as expected

        My suggestion:
        The user trying to access STS application should be the owner of the folder where STS is installed.

        I'm posting my reply here as its the most recently active thread about the similar issue as that of mine. I hope that helps.

        Comment


        • #5
          For whatever reason I periodically need to delete ~/.spring_roo_pgp.bpg when roo hangs, then restart STS and it's fine.
          YMMV

          Comment


          • #6
            I am having similar issues since yesterday. I have also posted on a different thread. I think that my problems begun to occur when I updated the version of dojo and brought a very large number of files under /src/resources. Right now it is obvious that STS is consuming the CPU and it is also obvious that it begins when I open the roo shell within STS. I am going to try a few things a report here. If anyone has fixed that same problem please let me know.

            I have the same problem wether I am using STS 2.9.1 or STS 3.0.0. I run OSX Mountain Lion, with 8 Gb Ram and SSD.

            Comment


            • #7
              Just to verify, these problems all seem to happen when the Roo shell is running under STS? What about if you run the Roo shell standalone? It is a pain to have to manually refresh (or set up STS to automatically detect changes when focus is detected, which can slow it down considerably) but will that work for you?

              During the writing of the book and any work I've done with Roo, I've personally stayed away from running the Roo shell in an IDE and so I haven't had that kind of issue. Just my experience. I like tab-based completion and a quickly managed shell (i.e. CTRL-C or kill -9 when it has any issues) so I have the command line open all of the time.

              Comment


              • #8
                Thanks for the tip. I'll try that moving forward. I did removed the files under the resources directory and I have had no issues since. I'll try to open up a ticket for it with SpringSource.

                Comment

                Working...
                X