Announcement Announcement Module
Collapse
No announcement yet.
STS Roo shell problem in perform tests Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS Roo shell problem in perform tests

    Hi,

    I'm using ubuntu 11.04 and tried to use roo but I had various configuration problems.

    Currently I have jdk1.6.0_33 installed, apache-maven-3.0.4, spring-roo-1.2.2.RELEASE, sts-3.0.0.RELEASE

    The JAVA_HOME folder, it's lib and it's bin have been set in the PATH environment variable. MAVEN_HOME as well and ROO_HOME as well. I tried both .profile and .bashrc files for setting these variables.

    I'm trying to run perform tests in the STS Roo shell with no success.

    The message I get is java.io.IOException: error=2, No such file or directory

    I can run perform tests from the command prompt, or maven test from the STS environment.

    Any Idea?

  • #2
    I think Spring Roo was no maven plugin support from STS environment.

    Comment


    • #3
      It looks yes...

      Both projects I tried (ten-minutes, pizza) suggest the standalone roo, althought they don't mention somewhere that the same commands cannot be used from the STS plugin.

      On the other hand, there was one (at least) related issue where Ben Alex mentioned that this is fixed From Cristian Dupuis, but in the commit there is mentioned only that there has been added something related to logging, which in any case doesn't seem to solve this problem.

      Comment

      Working...
      X