Announcement Announcement Module
Collapse
No announcement yet.
Spring Roo - perform eclipse - Proxy Authentication Required Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Roo - perform eclipse - Proxy Authentication Required

    Hi there,

    I saw some questions like this here before, but none of the answers provided a solution for me.

    I have Maven working through command-line as well as via m2eclipse by setting my Maven settings.xml and Eclipse proxy settings. All the issues that I had there are resolved.

    But when I execute "perform eclipse" in the Roo Shell on one of my educational Roo projects, I receive the following error(s):
    Code:
    org.springframework.roo:org.springframework.roo.annotations:jar:1.2.2.RELEASE: Could not transfer artifact org.springframework.roo:org.springframework.roo.annotations:pom:1.2.2.RELEASE from/to spring-maven-release (http://maven.springframework.org/release): Not authorized by proxy, ReasonPhrase:Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy filter is denied.  ).
    When I execute "proxy configuration" I receive kind of the following message (considering examplary correct data):
    Code:
    Proxy to use: HTTP @ proxy.hostname.local/01.02.03.04:8080
    I have supplied correct username and password data in the Maven settings.xml as well as in the Eclipse Preferences --> General --> Network Connections dialogs.
    Maven works by command-line and by m2eclipse, and I can still access the Eclipse Updates and Marketplace.

    How can I make sure Spring Roo accually uses the authentication information for the proxy server?
    Is this a bug in Roo?

    Thanks already for your help.

  • #2
    hi,
    I haven't seen that specific problem but ran into a similar issue fetching/loading dependencies for osgi bundles to use ROO DBRE against an Oracle Database and I expect the same fix is likely to work for you.


    I installed a a copy of cntlm http://cntlm.sourceforge.net/
    and set my roo_opts env variable before starting roo to something like

    ROO_OPTS=-Dhttp.proxyHost=127.0.0.1 -Dhttp.proxyPort=3128

    Comment


    • #3
      Hi chorrylan,

      Thx for your reply. I'll try it out as soon as I can and will check back in later on.

      Comment


      • #4
        The error has magically dissappeared and "perform eclipse" is working properly now. And without installing CNTLM.

        I only had to update the java version from 1.7 to 1.5, otherwise I would get "declare @type is only available from java 1.5 or later..." or something like that.
        Now the project is clean in STS.

        Comment

        Working...
        X