Announcement Announcement Module
Collapse
No announcement yet.
Maven Error From Integration Tests Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Maven Error From Integration Tests

    I am using spring roo and attempting to run integration tests but I get the following errors when I try to run "perform tests" from the roo shell in STS. Any ideas what could be wrong, looks like something with settings.xml but not sure what.

    Code:
    ~.Employee roo> perform tests
    [ERROR] Error executing Maven. 
    [ERROR] 8 problems were encountered while building the effective settings 
    [ERROR] 'servers.server[0].id' is missing @ C:\Users\tom\.m2\settings.xml 
    [ERROR] 'mirrors.mirror.id' for  is missing @ C:\Users\tom\.m2\settings.xml 
    [ERROR] 'mirrors.mirror.url' for  is missing @ C:\Users\tom\.m2\settings.xml 
    [ERROR] 'mirrors.mirror.mirrorOf' for  is missing @ C:\Users\tom\.m2\settings.xml 
    [ERROR] 'profiles.profile[].repositories.repository.id' for  is missing @ C:\Users\tom\.m2\settings.xml 
    [ERROR] 'profiles.profile[].repositories.repository.url' for  is missing @ C:\Users\tom\.m2\settings.xml 
    [ERROR] 'profiles.profile[].pluginRepositories.pluginRepository.id' for  is missing @ C:\Users\tom\.m2\settings.xml 
    [ERROR] 'profiles.profile[].pluginRepositories.pluginRepository.url' for  is missing @ C:\Users\tom\.m2\settings.xml 
     
    The command 'mvn.bat test' did not complete successfully
Working...
X