Announcement Announcement Module
Collapse
No announcement yet.
Roo Shell problems last couple days Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Roo Shell problems last couple days

    Is anyone else having troubles with the Roo shell? I'm finding it unbearably slow executing any type of command or even autocomplete (hangs for 10 secs or more on autocomplete). Both the CLI and the STS versions have been exhibiting this behavior for a couple days now for me and I'm not sure why.

  • #2
    Hi

    Im getting a similar problem. Im simply using Spring Roo 1.2.2 [rev 7d75659] simply form the command line.

    I setup a new folder and run the following commands:

    project --topLevelPackage org.mygroup --projectName demo

    persistence setup --database HYPERSONIC_IN_MEMORY --provider HIBERNATE

    web mvc setup

    I build the project and all is fine. Then whenever I go back to roo, it's taking an unbearable amount of time to do anything.

    Trying to auto-complete with tab hangs for about 10-20 seconds and you have no real idea when your cursor is going to come back.

    Even typing "exit" seems to take 20 seconds to actually leave the shell.

    Running on Windows 7 64-bit with an i7 Quad Core @ 2.67ghz, 6GB Ram and running off 128GB SSD.

    Very frustrating when you can see the potential with Roo but cant actually use it in a pratical way. Ive done a lot a searching and tried deleting the ~/.spring_roo_pgp.bpg as well but nothings working. Dont seem to be many others sufferring with this either so doubly frustrating.

    Any help would be greatly appreciated.

    Comment


    • #3
      Ok I thought I keep posting my findings as I delve further.

      I just deleted the whole project, and the ~/.spring_roo_pgp.bpg and loaded up roo console again.

      This time there are no delays or lags. So im guessing there is something in the pom.xml it creates it chews over? Im also wondering if its doing lookups for resources from whatever repositories are setup in the pom.xml or maven user settings.xml whenever a command is run?

      No answers yet but the plot thickens...

      Comment


      • #4
        Ok I think I've found something.

        I forgot to mention that I had added a custom plugin to auto-deploy it to my local Tomcat instance. Here's what I added to the pom.xml manually:

        <!-- Maven Tomcat Plugin -->
        <plugin>
        <groupId>org.codehaus.mojo</groupId>
        <artifactId>tomcat-maven-plugin</artifactId>
        <configuration>
        <url>http://${tomcatURL}/manager/text</url>
        <server>TomcatServer</server>
        <path>/${project.artifactId}-${project.version}</path>
        </configuration>
        <executions>
        <execution>
        <id>deploy-to-tomcat</id>
        <phase>install</phase>
        <goals>
        <goal>redeploy</goal>
        </goals>
        </execution>
        </executions>
        </plugin>

        Lo and behold, this is the cause of the lag. Basically when I add this and type "help" in roo console it takes 5-10secs whereas when I remove it, it's instant.

        Im only just starting out in roo, but what is it about adding plugins manually that causes the console to slow down so much?

        Comment


        • #5
          Apologies for the rambling (next time Ill put it all in one post)

          The problem is down to the fact that I didnt specify a version for the plugin. When I add the

          <version>1.1</version>

          to the plugin, the console behaves with no lag. Without it, it would appear to do a full scan of your ~/.m2/repository for *every* command you execute trying to find a suitable version.

          HTH

          Comment

          Working...
          X