Announcement Announcement Module
Collapse
No announcement yet.
java.lang.RuntimeException: The RequestFactory ValidationTool must be run for the de. Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • java.lang.RuntimeException: The RequestFactory ValidationTool must be run for the de.

    I am using sts-2.9.2.RELEASE, spring-roo-1.2.1.RELEASE, GWT 2.4 and try to do a VERY simple thing.
    Which does not work and i am quite puzzled that this combination is not usable for mere mortals.
    I created a new spring roo project within STS.

    For avoiding
    "Type Plugin execution not covered by lifecycle configuration: org.codehaus.mojo:exec-maven-plugin:1.2:exec (execution: default, phase: process-classes)"

    i did what is advised in http://forum.springsource.org/showth...166#post416166.
    Which is:

    1. Add to pom.xml

    Code:
    <!-- dp beg -->
    <pluginManagement>
    	<plugins>
    		<!--This plugin's configuration is used to store Eclipse m2e settings 
    			only. It has no influence on the Maven build itself. -->
    		<plugin>
    			<groupId>org.eclipse.m2e</groupId>
    			<artifactId>lifecycle-mapping</artifactId>
    			<version>1.0.0</version>
    			<configuration>
    				<lifecycleMappingMetadata>
    					<pluginExecutions>
    						<pluginExecution>
    							<pluginExecutionFilter>
    								<groupId>org.datanucleus</groupId>
    								<artifactId>maven-datanucleus-plugin</artifactId>
    								<versionRange>[1.1.4,)</versionRange>
    								<goals>
    									<goal>enhance</goal>
    								</goals>
    							</pluginExecutionFilter>
    							<action>
    								<ignore></ignore>
    							</action>
    						</pluginExecution>
    						<pluginExecution>
    							<pluginExecutionFilter>
    								<groupId>net.kindleit</groupId>
    								<artifactId>maven-gae-plugin</artifactId>
    								<versionRange>[0.7.3,)</versionRange>
    								<goals>
    									<goal>unpack</goal>
    								</goals>
    							</pluginExecutionFilter>
    							<action>
    								<execute />
    							</action>
    						</pluginExecution>
    						<pluginExecution>
    							<pluginExecutionFilter>
    								<groupId>
    									org.codehaus.mojo
    								</groupId>
    								<artifactId>
    									exec-maven-plugin
    								</artifactId>
    								<versionRange>
    									[1.2,)
    								</versionRange>
    								<goals>
    									<goal>exec</goal>
    								</goals>
    							</pluginExecutionFilter>
    							<action>
    								<ignore></ignore>
    							</action>
    						</pluginExecution>
    					</pluginExecutions>
    				</lifecycleMappingMetadata>
    			</configuration>
    		</plugin>
    	</plugins>
    </pluginManagement>
    <!-- dp end -->
    2. run mvn clean eclipse:clean
    3. import back into eclipse as maven project

    So far so good (actually not)
    As soon as i do Run as -> Web Application i get:

    "java.lang.RuntimeException: The RequestFactory ValidationTool must be run for the de."

    I tried to what is (horribly) documented at : Setting it manually as decribed in http://code.google.com/p/google-web-...faceValidation
    It had absolute ZERO effect.

    Can anyone PLEASe describe how to get this darn ValidationTool runnning?
Working...
X