Announcement Announcement Module
Collapse
No announcement yet.
JDBC driver not available for 'net.sourceforge.jtds.jdbc.Driver' Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • JDBC driver not available for 'net.sourceforge.jtds.jdbc.Driver'

    I'm trying to reverse engineer a ms sql database but running into this error.

    JDBC driver not available for 'net.sourceforge.jtds.jdbc.Driver'

    According to the docs ms sql is supported.

    My JPA setup has automatically added the jtds driver to my pom.

    However it looks like the dbre addon needs this driver.

    From working with oracle I assume this needs to be in an OSGI bundle.

    Reading around suggests that this driver should be available as an addon.

    It doesn't appear in any addon search. It's not in my list of osgi bundles installed.


    Why isn't it in my list of addons and how do I add it?


    I've tried with roo 1.2.1 and 1.2.2

  • #2
    Search for a MSSQL JTDS driver online, download it then do an "OSGI Start File:C:\\..." with the location of the download JTDS driver. Use the .jar file package inside of it. Hope this helps, I was never able to access any addons from my machine and needed to install everything manually.

    Comment


    • #3
      Thanks I done this and I can now connect to the mssql database and introspect the database.

      However reverse engineering the database seems to have issues regarding foreign key tables not existing when infact they do so not totally sucessfull yet.

      It seems there is some general problem with roo addons at the moment so I couldn't even automatically add the mysql driver. Theres an issue in the issue track but nobody is working on it at the moment.

      Comment


      • #4
        Seems to have worked around issue now. If it's of any use to others. here's my problem and solution.

        Seems that when I only want to include a few tables but they have foreign key constraints set up to other tables I either have to include them aswell or specifically exclude them.

        database reverse engineer --schema X --package ~.model --includeTables "X Y Z" --exludeTables "A B C"

        Comment

        Working...
        X