Announcement Announcement Module
No announcement yet.
Deploying spring roo project onto the tc server in STS Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Deploying spring roo project onto the tc server in STS

    Hi I am new to spring roo. I am using STS 2.9.2 and roo version 1.2.1.RELEASE. I created a roo project and tried to connect to a db2 database. I followed the steps mentioned in

    to get the osgi version of the db2jcc4.jar. I was able to connect and run database introspect --schema and also was able to run the database introspect --schema commands

    The problem is that when I deployed the project to the tc server which comes with STS I am getting the error

    ERROR org.hibernate.tool.hbm2ddl.SchemaValidator - could not get database metadata
    org.apache.commons.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory ([ibm][db2][jcc][10333][11649] No license was found. An appropriate license file db2jcc_license_*.jar must be provided in the CLASSPATH setting.)

    Does this mean I need to get a osgi version of db2jcc_license_cu.jar? I tried the following
    1. Installed the jar into my local maven repository

    mvn install:install-file -Dfile="C:\Program Files\IBM\SQLLIB_01\db2jcc_license_cu.jar" -DartifactId=db2jcc_license_cu -Dversion=10.1 -Dpackaging=jar -DgeneratePom=true

    2. I created the wraper project then ran the following to generate the pom.

    addon create wrapper --topLevelPackage --groupId --artifactId db2jcc_license_cu --version 10.1 --vendorName IBM --licenseUrl
    The generated pom is
    <?xml version="1.0" encoding="UTF-8" standalone="no"?>
    <project xmlns="" xmlns:xsi="" xsi:schemaLocation="">
        <description>This bundle wraps the standard Maven artifact: ${pkgArtifactId}-${pkgVersion}.</description>
                <id>Google Code</id>
                            <Bundle-Vendor>${pkgVendor} (wrapped into an OSGi bundle by the Spring Roo project build system)</Bundle-Vendor>

    3. mvn bundle:bundle
    But at this step I get the following error

    [INFO] ------------------------------------------------------------------------
    [ERROR] Failed to execute goal on project Could not resolve dependencies for project icense_cu:bundle:10.1.000
    1: Failure to find in was cached in the local repository, resolution will not be reattempted until the update interval of central
    has elapsed or updates are forced -> [Help 1]

    Which leads me to believe the db2jcc_license_cu.jar is not found in my local repository, but I can see it. Any tips to debug this? Some documents I need to read?

    I believe all the jars used for the roo projects need to be osgi, is that right? Is there some specific steps needed to deploy roo projects that use osgi jars? Can someone point me in the right direction?