Announcement Announcement Module
Collapse
No announcement yet.
Spring roo 1.2.1 and PrimeFaces 3.3 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring roo 1.2.1 and PrimeFaces 3.3

    Hello,

    I wish to integrate the latest PrimeFaces (PF) version to my actual roo project, the actual version of ROO, use 3.1.1 PF version. I try to find something to guide me to reach my goal, but I have not luck yet.

    The reason to use PF 3.3 is to get the new features and improvements that comes with PF 3.3.

    Someone knows if it is possible, and if YES, can You give me some tips/hints for 'how-to-do' ?

    As final solution to me, I think I can modify the .war file and change the jar version, but I think that this is not the best way to do it.

    Thank you.

    Best Regards for everyone
    Victor.

    p.s. I will change every generated component that I need with the new features.

  • #2
    Simply change the pom dependency for PrimeFaces from 3.1.1 to 3.3 and the themes to 1.0.5

    Comment


    • #3
      Originally posted by Alan Stewart View Post
      Simply change the pom dependency for PrimeFaces from 3.1.1 to 3.3 and the themes to 1.0.5
      Oh Yeah! simply as you said.

      Thank you Alan.

      Comment


      • #4
        I got to this thread due to an error, and apparently upgrading the version is not as easy as shown here.

        After upgrading Primefaces version I started to experience javascript errors (Object #<HTMLDivElement> has no method 'refresh' ) on Chrome and IE, and the dialogs would only open on Firefox.

        On Primefaces forums, I found that starting at version 3.2, component id and widgetVar cannot have the same name:

        http://forum.primefaces.org/viewtopic.php?f=3&t=18830

        Indeed, after changing the dialog's widgetVar, the Roo generated application worked fine.

        I've raise an improvement on Jira for that: https://jira.springsource.org/browse/ROO-3282
        Last edited by figura; Sep 18th, 2012, 05:58 PM.

        Comment


        • #5
          Originally posted by figura View Post

          I'll raise an improvement on Jira for that.
          Please do. Attaching a patch would also help speed up the process.
          Alan

          Comment


          • #6
            Improvement raised on Jira:

            https://jira.springsource.org/browse/ROO-3282

            I've attached a possible fix to Jira, but I still need to take some time and try to provide it in a patch format.

            I tried following the readme.txt on Github to set up a dev environment, but failed to use Eclipse for development. When importing the project into Spring Tool Suite, m2e pops lots of errors (http://wiki.eclipse.org/M2E_plugin_e...on_not_covered).

            Any guidance on the roo dev environment?

            Comment

            Working...
            X