Announcement Announcement Module
Collapse
No announcement yet.
Problem using Derby for DBRE on Roo 1.2.1 in STS 2.9.1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem using Derby for DBRE on Roo 1.2.1 in STS 2.9.1

    I invoke the command:

    database introspect --schema test

    and I get

    Code:
    Located add-on that may offer this JDBC driver
    1 found, sorted by rank; T = trusted developer; R = Roo 1.2 compatible
    ID T R DESCRIPTION -------------------------------------------------------------
    01 Y Y 10.8.1.2_0020 Derby #jdbcdriver...
    --------------------------------------------------------------------------------
    [HINT] use 'addon info id --searchResultId ..' to see details about a search result
    [HINT] use 'addon install id --searchResultId ..' to install a specific search result, or
    [HINT] use 'addon install bundle --bundleSymbolicName TAB' to install a specific add-on version
    JDBC driver not available for 'org.apache.derby.jdbc.EmbeddedDriver'
    So I issued this command with the following output:

    Code:
    addon install bundle --bundleSymbolicName org.springframework.roo.wrapping.derby;10.8.1.2_0020
    roo> Target resource(s):
    -------------------
       Spring Roo - Wrapping - derby (10.8.1.2_0020)
    
    Deploying...done.
    Subsequently, the database introspect command above gives the same message about the fact that there are no add-on offering that JDBC driver.

  • #2
    Does this happen in a standalone Roo shell?

    Comment

    Working...
    X