Announcement Announcement Module
Collapse
No announcement yet.
The goal you specified requires a project to execute but there is no pom in this dir Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • The goal you specified requires a project to execute but there is no pom in this dir

    "The goal you specified requires a project to execute but there is no pom in this directory"

    This directory is "blah blah blah\SpringRoo"

    I have pizza directory under "blah blah blah\SpringRoo", so the whole application is actually in this directory "blah blah blah\SpringRoo\pizza"

    But when I run perform tests, I got the "no pom in 'blah blah blah\SpringRoo' directory", but pom.xml is actuall under "blah blah blah\SpringRoo\pizza", and I ran 'roo' under "blah blah blah\SpringRoo\pizza".

    I think roo is not looking at the right directory, that is why it doesn't see pom.xml

    How can I tell roo to look into the right directory?

  • #2
    One more thing I would like to point out, I did completely went through once with the pizza example at http://static.springsource.org/sprin...beginning.html

    It was successful, and I deleted the pizza directory, and created a new pizza, and went through the tutorial for the second time, on which the errors showed
    Last edited by SpringFollower; Apr 16th, 2012, 02:22 AM.

    Comment


    • #3
      Attachment

      here is a screenshot
      Attached Files

      Comment


      • #4
        The blah blah blah doesn't make it very readable. And the screenshot is really hard to read.

        Comment


        • #5
          To simplified, when I ran "perform eclipse" command, i got the following error
          "Failed to execute goal org.apache.maven.plugins:maven-eclipse-plugin:2.9:clean(default-cli): Goal requires a project to execute but there is no POM in this directory (C:\SpringRoo)......"

          I don't know why it's checking C:\SpringRoo, when my application is actually in C:\SpringRoo\pizza, and POM is under C:\SpringRoo\pizza.
          Last edited by SpringFollower; Apr 18th, 2012, 04:46 AM.

          Comment


          • #6
            In which directory do you run the command ?

            Comment


            • #7
              C:\SpringRoo\pizza
              I ran "roo" first
              Then perform eclipse

              Comment


              • #8
                Check in your pom.xml file if you have not a parent directive pointing to a parent pom file.

                Comment


                • #9
                  Hello, could you show a sample section of pom.xml to where I can change what you were talking about?

                  Comment


                  • #10
                    Show me the content of your pom.xml file please.

                    If you have several pom.xml files then show me their directory location and their content.

                    Comment


                    • #11
                      here is the link to my pom.xml


                      http://pastebin.com/i4S3thhC

                      Thank you

                      Comment


                      • #12
                        You may have some outdate hidden eclipse related files in your directories.

                        Search for files of directories that start with a dot . and either remove them or look into them to see if you can find something fishy in there.

                        Otherwise you can run a mvn eclipse:clean command.

                        Comment


                        • #13
                          Does the problem happen on all of these commands ?

                          mvn clean compile

                          mvn clean test

                          mvn eclipse:eclipse

                          Comment


                          • #14
                            no the problem doesn't occur on those commands.

                            Only when I type command in roo

                            Comment


                            • #15
                              Does it happen only when you run the tests or also when you compile the main code ?

                              Comment

                              Working...
                              X