Announcement Announcement Module
Collapse
No announcement yet.
problem with "web mvc" command Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • problem with "web mvc" command

    After creating a new Roo project with SpringSource Tool Suite (Version: 2.9.1.RELEASE) I run the following commands in the Roo Shell:
    persistence setup --database H2_IN_MEMORY --provider HIBERNATE
    database properties set --key database.url --value jdbc:h2:tcp://localhost/~/test
    entity jpa --class com.as.portfolioassistant.domain.OptionCriteria
    field number --fieldName annualizedReturn --type java.lang.Integer

    Then if I run this command:
    web mvc setup
    or this
    web mvc scaffold --class com.as.portfolioassistant.web.OptionCriteriaContro ller

    Then I get a compile problem in the Problems Tab in webmvc-config.xml & it says "can't find ApplicationConversionServiceFactoryBean".

    I get around this issue by using the command:
    controller scaffold --entity ~.domain.OptionCriteria --class ~.web.OptionCriteriaController

    Roo says that this is deprecated and will be removed soon. Anyone else experience this?
Working...
X