Announcement Announcement Module
Collapse
No announcement yet.
Oracle Reverse Engineering Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Oracle Reverse Engineering

    I am trying to get the jdbc driver installed along with reverse engineering an oracle database. I set up a roo project with the necessary DB information, persistence.xml, database.properties....etc.

    The problem lies in the jdbc. I am about to go crazy. I have downloaded the oraclexe and use the ojdbc5 and 6. I tried to use the directions here...

    http://nidget.wordpress.com/2011/07/...th-spring-roo/

    I get to the point of reverse engineering but get the error message


    roo> database reverse engineer --schema dbaaccts
    Exception in thread "Spring Roo JLine Shell" java.lang.NoClassDefFoundError: jav
    ax/management/JMException
    at java.lang.Class.getDeclaredConstructors0(Native Method)
    at java.lang.Class.privateGetDeclaredConstructors(Cla ss.java:2389)
    at java.lang.Class.getConstructor0(Class.java:2699)
    at java.lang.Class.newInstance0(Class.java:326)


    I installed this package but still get the same problem... I see the package has the missing class.

    [ 74] [Active ] [ 1] Java Transaction API (1.1.0)
    [ 75] [Active ] [ 1] Java Resource API (1.5.0)
    [ 83] [Resolved ] [ 1] file:///C:\Java\jdk1.6.0_24\jre\lib\rt.jar
    [ 92] [Resolved ] [ 1] file:///C:\Applications\Projects_Roo\ACCTSLookup\os
    gi\target\com.oracle.roo.jdbc.ojdbc5-11.2.0.2.0001.jar
    [ 99] [Installed ] [ 1] J2EE Application Management Specification (1.0.1)
    [ 100] [Installed ] [ 1] MX4J JMX API and implementation (3.0.2)
    [ 102] [Installed ] [ 1] com-oracle-roo-jdbc (11.2.0.0001)





    I missed up a few times and tried to get rid of bundles 83 and 92 but can't do it because there is no bundleSymbolic names. Any help would be greatly appreciated....
Working...
X