Announcement Announcement Module
Collapse
No announcement yet.
Not able to create my first ROO project Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Not able to create my first ROO project

    Hi, I downloaded STS 2.8.1 release and tried to create a new project using ebook mentioned on ROO page http://spring-roo-repository.springs...d_with_Roo.pdf

    After following page no. 4,5,6,7 on 8th page there is written that Maven folder structure will be automatically created which will be as follows:
    • src/main/java
    • src/main/resources
    • src/test/java
    • src/test/resources

    But in my case Project with only JRE system library is created with no Maven folder structure.

    Please help. If I am missing anything?

    Thanks,
    Dev

  • #2
    Can you take screenshots of you carrying out the steps in the book please? (i.e. repeat the screenshots in the book but for your environment. Can't tell from what you've posted what the problem is.

    Comment


    • #3
      Hi Dev,

      I notice that your eclipse project has a red exclamation mark on it. This means that there is a "problem" with the project configuration.
      It should be listed in the "problems" window in Eclipse (Window | Show View | Problems)
      If it is complaining about M2_CLASSPATH (as I suspect it may be), you need to set up a classpath variable

      Comment


      • #4
        We found that some of the versions of the dependencies couldn't be found - after fixing those the project came up ok.

        Comment


        • #5
          How did you fix the depencies?

          Originally posted by mattharr View Post
          We found that some of the versions of the dependencies couldn't be found - after fixing those the project came up ok.
          Are these dependencies that ROO should have got right for you? How did you fix the dependencies - by hand?

          Comment


          • #6
            Originally posted by peetdenny View Post
            Hi Dev,

            I notice that your eclipse project has a red exclamation mark on it. This means that there is a "problem" with the project configuration.
            It should be listed in the "problems" window in Eclipse (Window | Show View | Problems)
            If it is complaining about M2_CLASSPATH (as I suspect it may be), you need to set up a classpath variable
            Red mark is because of errors shown in attached file Attachment and M2_REPO is set Attachment . Please suggest.

            Thanks,
            Dev
            Attached Files

            Comment


            • #7
              I got the Roo CLI and the project folders to create after I downloaded the new Roo 1.2.1 (the default was 1.1.5) and set the new ROO_HOME and Path to ROO_HOME/bin. Just to make sure, I also downloaded Maven 3.0.3 and set the Path for its bin, and I defined the M2_REPO variable to my C:/Users/myname/.m2/repository
              I ran the roo-test (i.e.
              mkdir roo-test
              cd roo-test
              roo quit) and got the Roo CLI in a cmd window and

              rmdir roo-test, of course

              Then after deleting the bad project, I selected the external Roo installation radio button and chose the Roo 1.2.1, Next, Finish
              I had to wait for Maven to complete
              and I got the Roo cli in eclipse. That is as far as I got today, it took all day. I just downloaded STS yesterday.

              Comment


              • #8
                Are these dependencies that ROO should have got right for you? How did you fix the dependencies - by hand?
                Yes, just fixed them by hand. Can't remember which ones they were exactly, I think it was a version of Primefaces we couldn't find, and maybe an aspectJ version. But we just found the latest, or a newer version that Maven could find, and referenced that. Thinking about it it could have been our Nexus routing that might have played into this. Then again things have changed a bit now that 1.2.1 is out.

                Does that help?

                Cheers,

                Matt

                Comment

                Working...
                X