Announcement Announcement Module
Collapse
No announcement yet.
Roo 1.2.0 and STS Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Roo 1.2.0 and STS

    Hi everybody,
    I have some problems with SpringRoo and STS integration.
    I'm very new to Roo (1 week...) so it's very likely that *I* am the cause of these problems.

    1. When creating a new Roo projects, it lacks the src/main/java and src/test/java folders. I solved it creating by hand and adding them to the build path. Is there a way to have Roo doing it for you

    2. Compiler doesn't seem to get aware of the aspects until you add MVC support. For example, if you implement the interface GrantedAuthority, and add to this class the field "authority", the AJ files are created correctly but the compiler will tell you that your class doesn't implement the method getAuthority() until you run "web mvc setup". Once you installed the MVC support, everything works fine.

    Regards,
    Stefano

  • #2
    Hi Stefano,

    I am also having the same problem...http://forum.springsource.org/showth...st-ROO-project

    If you have got any solution to the problem, please post.

    Thanks,
    Dev

    Comment


    • #3
      Hi Dev,
      you can solve by setting by hand the build folders and running the command "mvc setup" just after creating the persistance layer.
      Another solution -my recommended one- is to use Roo 1.1.x (commands are a little different but use 'hint' or CTRL + SPACE) until STS 2.9 with support for Roo 1.2.1 will be released.

      However, the problems I found are non-blocking problems that can be easily solved by hand.

      Bye,
      Stefano

      Comment

      Working...
      X