Announcement Announcement Module
Collapse
No announcement yet.
Build problem with 1.2.0 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Build problem with 1.2.0

    The following resource is not available in any repository:

    org.springframework.roo:org.springframework.roo.an notations:jar:1.2.0.RELEASE

    I am unable to build the project.

    Cheers, Fireball

  • #2
    If you're building from source, the version will be 1.2.1.BUILD-SNAPSHOT. I'm not sure why you're seeing 1.2.0.RELEASE unless you're using the actual 1.2.0 distribution. When using the released version, the annotations jar will automatically be downloaded. Try to copy it manually to appropriate maven repo directory

    Comment


    • #3
      I am not building from source, i used the distribution from the download site. Where do I get the resource?

      You can try yourself with the current 1.2.0 download and e.g. clinic.roo, I should not build.

      Comment


      • #4
        If you're using the distribution then the annotations jar should automatically be downloaded. If it doesn't come down, copy the jar from the distribution's annotations directory to the repo

        Comment


        • #5
          I manually installed the annotations jar to the repo, and after changing the aspectj version in the pom to the following I was able to build.
          Code:
              <properties>
                  <aspectj.version>1.6.12</aspectj.version>
                  <java.version>1.6</java.version>
                  <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
                  <roo.version>1.2.0.RELEASE</roo.version>
                  <slf4j.version>1.6.2</slf4j.version>
                  <spring.version>3.1.0.RELEASE</spring.version>
              </properties>

          Comment


          • #6
            I'm experiencing the exact same problem, any ideas on why the annotations jar doesn't come down automatically?

            I've checked my repository settings in my pom.xml but couldn't find anything unusual, i.e. the http://spring-roo-repository.springsource.org/release repository is included.

            Currently I'm not able to check whether copying the jar manually to my repo will solve my problem. I will check this tonight.

            Comment


            • #7
              Roo 1.2.0 is working fine for me. I even built it from source this morning.

              In a project that uses Java 5, the pom.xml has the properties slightly different. Take a look if it helps you:

              Code:
                  <properties>
                      <aspectj.version>1.6.12.M2</aspectj.version>
                      <java.version>5</java.version>
                      <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
                      <roo.version>1.2.0.RELEASE</roo.version>
                      <slf4j.version>1.6.2</slf4j.version>
                      <spring.version>3.1.0.RELEASE</spring.version>
                  </properties>

              Comment

              Working...
              X