Announcement Announcement Module
Collapse
No announcement yet.
Roo 1.2 doesn't detect file changes? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Roo 1.2 doesn't detect file changes?

    I wonder if I'm alone in my experience that Roo 1.2 suddenly doesn't recreate or update its itd files? This renders the project unbuildable and causes really strange cascading errors. The only way to get the project back on track is to have version-saved also the itds and after deleting the current itd files get back the last working versions. In one project I had to restart the whole project from scratch because the backups were also acting up.

    I don't see a pattern for this problem and it happens quite seldom every 2-3 weeks or so.
    jdk1.5 and openjdk7.

  • #2
    I'm suffering problems like the ones MiB reported.

    The Roo shell is quite slow in detecting code changes. When I see it not acting for too long, I close it and restart it again. After restarted, it detects code changes flawlessly again.

    I'm working in STS 2.6.1.RELEASE, with Roo 1.2.0.RELEASE, on Windows 7.
    JDK Oracle 1.6u28.

    Regards,
    Vito Meuli

    Comment


    • #3
      Thanks for your input, Vito. However, if you're actually using STS 2.6.1 with Roo 1.2 running inside STS then I believe you cannot expect it to work. If Roo is running outside of STS it should work. As far as I know STS 2.8.1 is the first version compatible with Roo 1.2. Of course, it could be it was only the pre-release versions of Roo that were affected and that this is not true for Roo 1.2.RELEASE.

      But could you install STS 2.8.1.RELEASE separately and try Roo 1.2 there as well?

      Comment


      • #4
        Originally posted by MiB View Post
        But could you install STS 2.8.1.RELEASE separately and try Roo 1.2 there as well?
        Thanks for your advise. I will give it a try and let you know if it solved the issue.

        Kind regards,
        Vito Meuli

        Comment


        • #5
          Originally posted by MiB View Post
          But could you install STS 2.8.1.RELEASE separately and try Roo 1.2 there as well?
          STS 2.8.1 is working much better, it's never failed detecting code changes until now.
          Many thanks!
          Vito Meuli

          Comment


          • #6
            Originally posted by Vito Meuli View Post
            STS 2.8.1 is working much better, it's never failed detecting code changes until now.
            You mean it hasn't failed to detect file changes at all so far, right? Or did you mean it worked, but now it just failed?

            Comment


            • #7
              Originally posted by MiB View Post
              STS 2.8.1 is working much better, it's never failed detecting code changes until now.
              You mean it hasn't failed to detect file changes at all so far, right? Or did you mean it worked, but now it just failed?
              It hasn't failed to detect file changes at all so far :-)
              Sorry, I didn't know there's a subtle difference between "so far" and "until now": I'll keep improving my English :-)

              Comment


              • #8
                I'm using STS 2.8.1 with Roo 1.2.0 and I have seen the same behaviour explained by Vito in his first post on this thread. I wonder if the problem happens only after a long period of time with Roo open and "listening" for changes. Just saying that because if I remember well, I started seeing problems after waking up my pc (it was left to sleep, maybe even hybernate) with STS/Roo running.

                Also, restarting Roo on the CLI solved the problem (I had to restart Roo so force it to update the ITD files.

                Comment

                Working...
                X