Announcement Announcement Module
Collapse
No announcement yet.
problem with jtds (for Sybase) Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • problem with jtds (for Sybase)

    OK, folks, I was trying to do a reverse engineering task, and after doing the database introspect --schema no-schema-required, I did NOT get any addon information (not sure why that is).

    Looking at various forums, I found the link to DL the jtds jar (org.springframework.roo.wrapping.jtds-1.2.4.0010.jar).
    I then did osgi install --url file:///c:\pathtojar\org.springframework.roo.wrapping.jtds-1.2.4.0010.jar

    ooking at the osgi bundles, I see:
    [78] [Resolved ] [ 1] Spring Roo - Wrapping - jtds(1.2.4.0010)

    So far so good, but when I tried to do the:
    datatbase instrospect .... command (or the reverse engineering) I get:
    Connection required.

    If I try to START this:
    osgi start --url file:///C:\pathtojar\org.springframework.roo.wrapping.jtds-1.2.4.0010.jar
    I get:
    org.osgi.framework.BundleException: Bundle symbolic name and version are not unique: org.springframework.roo.wrapping.jtds:1.2.4.0
    010
    Bundle ID file:///C:\pathtojar\org.springframework.roo.wrapping.jtds-1.2.4.0010.jar is invalid.

    SO, how do I a) get this bundle to START
    Or how to uninstall :
    roo> osgi uninstall --bundleSymbolicName org.springframework.roo.wrapping.jtds-1.2.4.0010.jar
    Bundle symbolic name 'org.springframework.roo.wrapping.jtds-1.2.4.0010.jar' has no local bundle ID at this time

    Looks like I'm messed up here -- anyway to "clean" the bundles installed for Roo?

  • #2
    Just an update:
    I did:
    osgi update --bundleSymbolicName org.springframework.roo.wrapping.jtds
    once I did this, it let me UNINSTALL that bundle, and then when I did the database introspect command, it DID show the addon information (which it did not before I manually installed it)!
    It now shows in the bundle list as Active.

    HOWEVER, when I re-run the database instrospect command, I am still getting:
    "connnection required" (I have already updated the database.properties file.

    Comment


    • #3
      Looks like I'm messed up here -- anyway to "clean" the bundles installed for Roo?
      I usually just delete the "cache" directory under the Roo distribution root.

      I have tested the jtds driver with MSSQL as I don't have access to a Sybase database and it worked OK.

      Comment


      • #4
        Thanks Alan -- much appreciated. I've just started using roo, so still trying to get the lay of the land here!
        I did get it to work with Sybase -- the jtds connection string is different from the standard Sybase jconn3 string.

        Comment

        Working...
        X