Announcement Announcement Module
Collapse
No announcement yet.
roo does not create source folder (src/main/java) Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • roo does not create source folder (src/main/java)

    Hi,
    not sure if this happens on purpose, but if I create a new roo project the src/main/java (default packaging jar) folder is not created.

    I also started my own addon with where I use the AbstractPackagingProvider and return Path.SRC_MAIN_JAVA and Path.SRC_MAIN_RESOURCES in the getPaths method
    If create a new project or module with that custom packaging also none of these pathes get created.



    What do I miss? I use Roo 1.2 Release, ubuntu 11.10 with openjdk 7
    Thanks in advance
    max
    Last edited by maxb; Dec 18th, 2011, 03:12 AM.

  • #2
    I have the same problem with 1.2.0 RELEASE

    Using:
    Windows 7 x64
    JDK 1.6 and JDK 1.7
    Maven 2 and Maven 3

    tried everything I guess?
    Following the guide in the PDF.

    Working great with Roo 1.1.5

    Comment


    • #3
      So what happens if you issue an entity jpa command?

      Comment


      • #4
        maxb, I recommend you compile your own spring roo from git source as you're using openjdk7. On OS X 10.5.8 PPC and openjdk7, I couldn't run Roo1.2 at all before I did that. There is a problem with assembling to a single jar, but I'm hoping for a solution for that. Meanwhile I use roo-dev in bootstrap folder.

        Comment


        • #5
          Originally posted by MiB View Post
          So what happens if you issue an entity jpa command?
          Works
          Thanks.

          Comment


          • #6
            the jpa setup does not create the src/main/java but the entity jpa does create it, but the thing is that STS does not add then this folder to the classpath.

            So this might be an STS bug, but still the getPath method in the AbstractPackagingProvider confuses me since it seems that it does not do anything on project/module creation.
            I'll try to compile/package it from git

            maxb

            Comment


            • #7
              It doesn't pick it up even after refresh? Have you tried starting up with
              -clean
              -refresh

              on the first 2 lines of STS.ini?

              Comment


              • #8
                the -refresh -clean didn't work, but left click on the project -> maven -> update project configuration... did the trick.

                thanks
                maxb

                Comment

                Working...
                X