Announcement Announcement Module
Collapse
No announcement yet.
Spring Roo 1.2.0.RELEASE available now Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    So what are you saying, Alan. I must hack your install script?

    Comment


    • #17
      Yes, or alternatively use the Sun JDK 6
      Last edited by Alan Stewart; Dec 21st, 2011, 07:28 PM.

      Comment


      • #18
        This is mine...

        D:\InetPub\JavaWeb>java -version
        java version "1.7.0_02"
        Java(TM) SE Runtime Environment (build 1.7.0_02-b13)
        Java HotSpot(TM) 64-Bit Server VM (build 22.0-b10, mixed mode)

        D:\InetPub\JavaWeb>roo
        ____ ____ ____
        / __ \/ __ \/ __ \
        / /_/ / / / / / / /
        / _, _/ /_/ / /_/ /
        /_/ |_|\____/\____/ 1.2.0.RELEASE [rev 39eb957]


        Welcome to Spring Roo. For assistance press TAB or type "hint" then hit ENTER.
        InvocationTargetException at sun.reflect.NativeConstructorAccessorImpl.newInsta n
        ce0(Native Method)
        roo> hint
        InvocationTargetException at sun.reflect.GeneratedConstructorAccessor11.newInst a
        nce(Unknown Source)
        roo>

        Comment


        • #19
          i use java 7 update 2...

          you use java 7

          Comment


          • #20
            Did script expenses.roo work without error ????????????????????

            I have a question about roo 1.2.0.RELEASE.

            Did script expenses.roo work STS 2.8.1 with GWT 2.4.0 without error.
            Because I am having always a Maven error: Plugin execution not covered by lifecycle configuration: org.codehaus.mojo:exec-maven-plugin:1.2:exec.

            I try with different help forum links like a http://forum.springsource.org/showth...e-with-GWT-2-4 or http://forum.springsource.org/showth...116776-Roo-GWT. I still have the same maven error. I am asking if this error will be resolved with the next version of spring-roo releases ?


            This is script:
            // project --topLevelPackage org.springsource.roo.extrack

            jpa setup --provider HIBERNATE --database HYPERSONIC_IN_MEMORY

            enum type --class ~.shared.domain.Gender
            enum constant --name MALE
            enum constant --name FEMALE

            entity jpa --class ~.server.domain.Employee --testAutomatically
            field string --fieldName displayName --notNull
            field string --fieldName userName --sizeMin 3 --sizeMax 30 --notNull
            field string --fieldName department
            field reference --type Employee supervisor
            field enum --fieldName gender --type ~.shared.domain.Gender
            field boolean --fieldName admin --notNull

            entity jpa --class ~.server.domain.Report --testAutomatically
            field string --fieldName purpose
            field string --fieldName notes
            field date --fieldName created --type java.util.Date
            field string --fieldName department
            field reference --type Employee reporter
            field reference --type Employee approvedSupervisor

            entity jpa --class ~.server.domain.Expense --testAutomatically
            field number --type java.lang.Double amount
            field string --fieldName description
            field reference --type Report report
            field string --fieldName approval
            field string --fieldName category
            field date --fieldName created --type java.util.Date
            field string --fieldName reasonDenied

            web gwt setup
            web gwt all --proxyPackage ~.client.proxy --requestPackage ~.client.request

            logging setup --level INFO

            Comment


            • #21
              Is spring roo 1.2.0.RELEASE compatible with spring framework 3.1.RELEASE ? Is it safe to update to sf 3.1?
              Well, I guess I had to upgrade from 3.0.5 to 3.1 since @RequestParam 'produces' attriibute has been added by roo 1.2 and did not update pom.xml. So far, so good.
              Last edited by bogdan10; Dec 26th, 2011, 07:35 PM.

              Comment


              • #22
                Hi..
                I already downloaded spring roo 1.2.0RC1 and created new project. I notice that there is no "FINDER" view only Create and List..unlike in web mvc. Although the finder was stated in the created entity.
                Is there any command that we need to add in creating finder?
                Thanks.

                Comment


                • #23
                  I'm seeing the same problem and also struggling to resolve-- by which I mean, the answers I've turned up from Googling haven't worked yet.

                  I'm also seeing issues in the Java code with ReportLocator.java and in some of the aspect code for exceptions and constraint violations.

                  I'm working with 1.2.0 release under STS 2.8.1.

                  Comment


                  • #24
                    NativeConstructorAccessorImpl.newInstance0

                    Originally posted by vondie View Post
                    roo 1.2.0 can run in java 7 but with the following error:

                    InvocationTargetException at sun.reflect.NativeConstructorAccessorImpl.newInsta n
                    ce0(Native Method)

                    every time you type hint... the following error will appear:

                    InvocationTargetException at sun.reflect.GeneratedConstructorAccessor11.newInst a
                    nce(Unknown Source)
                    I have the same problem ('though using standard Oracle Java 6) and I've been wrestling with it now for a day or so, however I haven't come to any firm conclusion I'm afraid.

                    What I can say is that I can re-create the problem easily simply by first of all deleting my target folder and then running my JUnit tests. Deleting the target folder allows Roo to start (I get the problem whether I use STS or not) but once I run my unit tests and restart Roo, Roo gives the error NativeConstructorAccessorImpl.newInstance0.

                    So I have a work around but in case deleting the target folder doesn't work for others I've also noticed that during my upgrade from Roo 1.2.0.M1 I had to delete all the generated aspect J files for my domain objects only (forcing Roo to regenerate them from scratch) and if that doesn't work the other thing I did was to start again with a new pom.xml (I created a temporary project with the same top level package and set-up the same persistence and web settings) and manually copy all of your project specific dependencies etc.

                    Some combination of the above worked for me and I hope it works for others.
                    Last edited by tedp; Jan 4th, 2012, 07:41 AM.

                    Comment


                    • #25
                      I must say I am very pleased with 1.2 the JSF/Primefaces looks great and is much easier to use than Apache Tiles and Dojo.

                      Comment


                      • #26
                        Originally posted by MikeOliverAZ View Post
                        I must say I am very pleased with 1.2 the JSF/Primefaces looks great and is much easier to use than Apache Tiles and Dojo.
                        Really? You like coding GUI's with the java faces API?

                        Comment


                        • #27
                          Aloha from the Philippines! want to learn more about Roo!

                          Comment


                          • #28
                            Anyone has any luck with the OS command? I typed '!' and got the prompt back. I typed '!!' and I was suggested to install an addon. (spring-roo-os-commands (0.1.1.RELEASE))

                            Restart roo got 'Cannot specify an availability indicator for '!' more than once'.

                            Does OS command actually work in 1.2.0 release?

                            Thx.

                            Comment


                            • #29
                              Originally posted by samfndr View Post

                              Does OS command actually work in 1.2.0 release?
                              Okay, I figured out. The command that I used to test is 'ls' on Mac OS X. This works with the Grails 2.0 prompt: '!ls'. Roo 1.2 needs this: '! ls'. I wish the documentation could tell me that... or make it more friendly like Grails.

                              Thx.

                              Sam

                              Comment


                              • #30
                                JSF/Primefaces isn't working correctly for @NotNull fields, it simply doesn't verify, I can add data without the "required" fields because they're not validated, I think it's a bug.

                                Comment

                                Working...
                                X