Announcement Announcement Module
Collapse
No announcement yet.
Roo & Spring Framework 3.1? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Roo & Spring Framework 3.1?

    I'm just getting back into Spring technologies after a hiatus. I wanted to get started using the latest/greatest versions so I downloaded the latest GA releases of STS (2.8.1.RELEASE) & Roo (1.1.5.RELEASE) within the last several days. I saw the notifications today of the 3.1 framework release and realized that I was not aware of how the various product release cycles affect the use of these related products together. IOW, is it possible/practical to use the 3.1 FW with Roo 1.1.5? Is it just a matter of modifying the Spring FW version in your maven POMs or are there other compatibility issues to consider? Is there an upcoming release of Roo that is designed with FW 3.1 compatibility in mind? How are the release cycles usually handled for these related products (i.e. is there usually close coordination between releases)?

    I know that I could have answered these questions myself while I was actively using these products in the past but it appears that those brain cells are still on hiatus.

    Thanks for any help,
    Gary

  • #2
    You might have seen that Roo1.2Release is available now.

    Comment


    • #3
      Thanks for the update; I hadn't seen this.

      I downloaded it and scoured the Spring web site and can't find any indication of compatibility with the 3.1 FW. Any idea of whether this is part of the release?

      Comment


      • #4
        Nope, but if you read the release for Spring 3.1 the wording is such regarding backward compatibility with Spring 3.0.x projects that I would try 3.1 if I wasn't in Spring 3.0.x already mid-project and if I needed the new stuff in 3.1. Midproject is where I find myself at the moment.

        Why not take the plunge in a test project for one day and play around? If you have to be productive I would make do with what Roo 1.2 chooses for me.

        Comment

        Working...
        X