Announcement Announcement Module
Collapse
No announcement yet.
Problem moving Roo project from 2.8.0 to 2.8.1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem moving Roo project from 2.8.0 to 2.8.1

    I have a Roo project that I was working on that was doing fine on 2.8.0 having started on 2.7.2.

    When the automatic updates showed a 2.8.1 upgrade available I installed it and that project immediately stopped working and would hang whenever I tried to run as on server.

    I have reverted to the standard install of 2.8.0 and 2.8.1 for reference with same result, works on 2.8.0 and not on 2.8.1.

    Without any changes to the project code or configuration after importing the same project from a working instance of 2.8.0 to a new workspace with 2.8.1 I get a hang when I try to run it. Trace logs show...

    Code:
    14:56:18,963 DEBUG ResourceHttpRequestHandler:155 - Trying relative path [dojo-1.6/dijit/_base/sniff.js] against base location: class path resource [META-INF/web-resources/]
    14:56:18,964 DEBUG ResourceHttpRequestHandler:160 - Found matching resource: class path resource [META-INF/web-resources/dojo-1.6/dijit/_base/sniff.js]
    14:56:18,964 DEBUG ResourceHttpRequestHandler:112 - Determined media type [text/javascript] for class path resource [META-INF/web-resources/dojo-1.6/dijit/_base/sniff.js]
    14:56:18,965 DEBUG SimpleMappingExceptionResolver:132 - Resolving exception from handler [org.springframework.web.servlet.resource.ResourceHttpRequestHandler@48ec77cb]: ClientAbortException:  java.net.SocketException: Connection reset by peer: socket write error
    14:56:18,965 DEBUG SimpleMappingExceptionResolver:173 - Resolving to default view 'uncaughtException' for exception of type [org.apache.catalina.connector.ClientAbortException]
    14:56:18,965 DEBUG SimpleMappingExceptionResolver:294 - Exposing Exception as model attribute 'exception'
    14:56:18,966 DEBUG DispatcherServlet:1001 - Handler execution resulted in exception - forwarding to resolved error view: ModelAndView: reference to view with name 'uncaughtException'; model is {exception=ClientAbortException:  java.net.SocketException: Connection reset by peer: socket write error}
    ClientAbortException:  java.net.SocketException: Connection reset by peer: socket write error
    	at org.apache.catalina.connector.OutputBuffer.doFlush(OutputBuffer.java:319)
    	at org.apache.catalina.connector.OutputBuffer.flush(OutputBuffer.java:288)
    	at org.apache.catalina.connector.CoyoteOutputStream.flush(CoyoteOutputStream.java:98)
    	at org.springframework.util.FileCopyUtils.copy(FileCopyUtils.java:116)
    	at org.springframework.web.servlet.resource.ResourceHttpRequestHandler.writeContent(ResourceHttpRequestHandler.java:210)
    	at org.springframework.web.servlet.resource.ResourceHttpRequestHandler.handleRequest(ResourceHttpRequestHandler.java:135)
    	at org.springframework.web.servlet.mvc.HttpRequestHandlerAdapter.handle(HttpRequestHandlerAdapter.java:49)
    	at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:790)
    and 37 more...
    comparing project trees the two projects are identical.

    I have cleaned the working directory and run it on both tomcat 6 and the vfabric tc with no difference.

    Any clues how to fix it so it will run on 2.8.1?

  • #2
    More info.

    Environment sts 2.8.1 on win 7 64bit with java jdk 1.6

    non Roo projects import and run just fine.

    Some Spring Roo projects do not.

    Tried on three with three different flavors.

    Simple Roo project with no push in refactoring. Works fine.
    Create Complex Roo project with push in refactoring. Works fine.
    Import Complex Roo project with push in refactoring. Gives the above exception and hangs, on two similar projects.

    Current solution, puke, gag, ouch...Use Spring Roo and a modified Roo log of the old project to create a new project in 2.8.1, when that is running and it has first time both times I have tried this. Then push in refactor and synchronize sources with the 2.8.0 project externally to STS with WinMerge.

    Then it runs. I have compared files in the two trees and after many hours could not find a difference that would possibly matter.

    Comment


    • #3
      Differences

      I want to modify my statement that I found no differences. I found no differences in the sources, but in the project.settings folder there are two files in teh 2.8.1 that are not in the 2.8.0 projects.

      org.eclipse.core.resources.prefs
      org.eclipse.m2e.core.prefs

      Comment


      • #4
        Maven clean followed by Maven Install offers no errors and Build Success, but the above hang still occurs.

        Comment


        • #5
          More information.

          I was using Firebug and I noticed that it couldn't find some .js resources. I figured Ah Ha! and started tracing back. Only thing is everything was where it should be and has been, nothing moved, yet it couldn't find it. STS hung as before and I killed it. Now here is the new information. Tomcat was still running on that application, and I refreshed the screen and the application reloaded and it found all the .js resources and the application runs fine.

          Will try some other run time configuration options, I was using the default metadata option before.

          Comment


          • #6
            Tried option two in run time configuration to take over tomcat 6 or 7 same result. STS hangs, but when you kill STS tomcat stays running and the application loads and runs fine.

            Comment


            • #7
              Ok while not a solution per se, because I still don't know the cause. The work around is to create a new Roo project with the same name as the old project. Use the Roo.log from the old project to script create the new project. Then if you need to push in, push in first on the new project, then synchronize sources.

              I found that with STS 2.8.1 using the internal browser doesn't work on larger projects and may be timing out, closing the socket and causing the hang.

              I changed to use the Firefox browser on run as->run on server and that works just fine on run and debug when starting the server from STS.

              I found no difference in run time configuration options when using the internal browser.

              Good luck and if anyone knows the cause or a setting or configuration option to avoid rebuilding the project, please reply here the time you spend will be a pay forward for those of us that need to know.

              Comment

              Working...
              X