Announcement Announcement Module
Collapse
No announcement yet.
Roo 1.2.0RC1 hangs on script running Ubuntu and Windows STS 2.8.1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Roo 1.2.0RC1 hangs on script running Ubuntu and Windows STS 2.8.1

    Hi,

    I tried Roo 1.2.0RC1 today on Ubuntu with STS 2.8.1 at work and created an empty roo project and then run the expenses.roo sample script. It seems to stop on setting up the project after the persistence script line and does not continue. I try on 1.1.5 and the scripts work fine.

    So, i get home from work and try on my windows laptop STS 2.8.1 with Roo 1.2.0RC1 and has same problem. First seems to be maven issue that it cant find the repo to download the files or the files are missing. So i do a maven update dependencies and force update with the checkbox in STS and that seems to clear that problem.

    But then I find that I still cant run the expenses.roo or clinic.roo scripts and it hangs on the first script line. You can see below i try to run the console and what happens, and then later I manually enter commands (the enums to generate) but it does not produce any results / code generation or error messages.

    Anyone else getting problems with Roo 1.2.0RC1 ? or know how to fix it ? seems horribly broken.

    Roo 1.2.0M1 i can run scripts fine here on windows but not tried yet on Ubuntu with STS 2.8.1

    ____ ____ ____
    / __ \/ __ \/ __ \
    / /_/ / / / / / / /
    / _, _/ /_/ / /_/ /
    /_/ |_|\____/\____/ 1.2.0.RC1 [rev dcaa483]


    Welcome to Spring Roo. For assistance press CTRL+SPACE or type "hint" then hit ENTER.
    roo>
    required --file: The file to locate and execute; no default value
    roo> script --file samples\clinic.roo
    project --topLevelPackage com.springsource.petclinic

    jpa setup --provider HIBERNATE --database HYPERSONIC_IN_MEMORY
    Created SPRING_CONFIG_ROOT\database.properties
    Updated SPRING_CONFIG_ROOT\applicationContext.xml
    Created SRC_MAIN_RESOURCES\META-INF\persistence.xml
    Updated ROOT\pom.xml [added dependencies org.hsqldb:hsqldb:1.8.0.10, org.hibernate:hibernate-core:3.6.8.Final, org.hibernate:hibernate-entitymanager:3.6.8.Final, org.hibernate.javax.persistence:hibernate-jpa-2.0-api:1.0.1.Final, org.hibernate:hibernate-validator:4.2.0.Final, javax.validation:validation-api:1.0.0.GA, cglib:cglib-nodep:2.2.2, javax.transaction:jta:1.1, org.springframework:spring-jdbc:${spring.version}, org.springframework:spring-orm:${spring.version}, commons-pool:commons-pool:1.5.4, commons-dbcp:commons-dbcp:1.3]
    roo> enum type --class ~.shared.domain.Gender
    roo> test
    Command 'test' not found (for assistance press CTRL+SPACE or type "hint" then hit ENTER)
    addon search --requiresCommand "test" found no matches
    roo> enum type --class ~.shared.domain.GenderMale
    roo> enum type --class ~.shared.domain.GenderMaleTest

  • #2
    Hi,

    Seems to be another post thats similar. Issue is with 2.8.1 STS shell and Roo some sort of clash.. but i dont see that stack trace they have.

    See:

    http://forum.springsource.org/showth...1-2RC1-and-STS

    How about testing the latest release of Roo with the latest / current realease of STS in future before you release roo to the public and save us all headache.

    I will try the roo shell in terminal outside of sts and it may work on running the scripts. Ill follow up with that tomorrow if im successful.

    carlo

    Comment

    Working...
    X