Announcement Announcement Module
No announcement yet.
DBRE/gwt scaffold omits locators Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • DBRE/gwt scaffold omits locators

    I get the following ClassNotFoundException when I reverse engineer an oracle (ojdb6) table and try to scaffold it via web gwt setup followed by web gwt all:

    [ERROR] Dec 4, 2011 6:17:14 PM ceLayerDecorator die

    [ERROR] SEVERE: Could not find the locator type specified in the yForName

    [ERROR] java.lang.ClassNotFoundException: r

    The corresponding locator for my reverse-engineered entity is not generated. This is not the case when I run expenses.roo script, which is the behavior I expected when I used DBRE.

    Is this behavior expected?

    Are we required to write the locators by hand when we use DBRE?

    Is there something in the reference docs that I am overlooking?
    Last edited by wil.pannell; Dec 4th, 2011, 06:24 PM. Reason: CLARITY

  • #2
    Hi Wil,

    I came across the exact same problem. Pls share the details, if you have solved it. Thanks in advance.