Announcement Announcement Module
Collapse
No announcement yet.
Roo shell crash Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Roo shell crash

    Hi,
    I have problem with starting roo shell with command line on Windows XP SP3 with roo.bat. I've also tried in cygwin with roo.sh, and in Idea 10.5 with the plugin and I get the same error. I've checked the paths and they all seem to be correct. What's wrong here? Curiously, the shell works in STS 2.8, but it has its own copy of Roo. What's wrong here?
    Code:
    Here are some exceptions:
    C:\Java\Tools\Spring\Roo\spring-roo-1.1.5>java -Dflash.message.disabled=false -Djline.nobell=true  -Droo.args="" -Ddevel
    opmentMode=false -Dorg.osgi.framework.storage="C:\Java\Tools\Spring\Roo\spring-roo-1.1.5\cache" -Dfelix.auto.deploy.dir=
    "C:\Java\Tools\Spring\Roo\spring-roo-1.1.5\bundle" -Dfelix.config.properties="file:C:\Java\Tools\Spring\Roo\spring-roo-1
    .1.5\conf\config.properties" -cp "C:\Java\Tools\Spring\Roo\spring-roo-1.1.5\bin\org.apache.felix.framework-3.0.7.jar;C:\
    Java\Tools\Spring\Roo\spring-roo-1.1.5\bin\org.springframework.roo.bootstrap-1.1.5.RELEASE.jar;" org.springframework.roo
    .bootstrap.Main
    ERROR: Error starting file:/C:/Java/Tools/Spring/Roo/spring-roo-1.1.5/bundle/org.springframework.roo.addon.backup-1.1.5.
    RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.backup [7
    ]: Unable to resolve 7.0: missing requirement [7.0] package; (&(package=org.springframework.roo.file.monitor.event)(vers
    ion>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 39.0: missing requirement [39.0] package; (&(package=org.s
    pringframework.roo.support.ant)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 52.0: missing requirem
    ent [52.0] package; (package=javax.xml.namespace)]])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.backup [7]: Unable to
    resolve 7.0: missing requirement [7.0] package; (&(package=org.springframework.roo.file.monitor.event)(version>=1.1.0)(!
    (version>=2.0.0))) [caused by: Unable to resolve 39.0: missing requirement [39.0] package; (&(package=org.springframewor
    k.roo.support.ant)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 52.0: missing requirement [52.0] pa
    ckage; (package=javax.xml.namespace)]]
            at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
            at org.apache.felix.framework.Felix.startBundle(Felix.java:1719)
            at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148)
            at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
            at java.lang.Thread.run(Unknown Source)
    ERROR: Error starting file:/C:/Java/Tools/Spring/Roo/spring-roo-1.1.5/bundle/org.springframework.roo.addon.configurable-
    1.1.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.con
    figurable [8]: Unable to resolve 8.0: missing requirement [8.0] package; (&(package=org.springframework.roo.classpath)(v
    ersion>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 36.0: missing requirement [36.0] package; (&(package=or
    g.springframework.roo.file.monitor)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 39.0: missing requ
    irement [39.0] package; (&(package=org.springframework.roo.support.ant)(version>=1.1.0)(!(version>=2.0.0))) [caused by:
    Unable to resolve 52.0: missing requirement [52.0] package; (package=javax.xml.namespace)]]])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.configurable [8]: Unab
    le to resolve 8.0: missing requirement [8.0] package; (&(package=org.springframework.roo.classpath)(version>=1.1.0)(!(ve
    rsion>=2.0.0))) [caused by: Unable to resolve 36.0: missing requirement [36.0] package; (&(package=org.springframework.r
    oo.file.monitor)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 39.0: missing requirement [39.0] pack
    age; (&(package=org.springframework.roo.support.ant)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 5
    2.0: missing requirement [52.0] package; (package=javax.xml.namespace)]]]
            at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
            at org.apache.felix.framework.Felix.startBundle(Felix.java:1719)
            at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148)
            at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
            at java.lang.Thread.run(Unknown Source)
    ERROR: Error starting file:/C:/Java/Tools/Spring/Roo/spring-roo-1.1.5/bundle/org.springframework.roo.addon.creator-1.1.5
    .RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.creator
    [9]: Unable to resolve 9.0: missing requirement [9.0] package; (package=javax.xml.parsers))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.creator [9]: Unable to
     resolve 9.0: missing requirement [9.0] package; (package=javax.xml.parsers)
            at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
            at org.apache.felix.framework.Felix.startBundle(Felix.java:1719)
            at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148)
            at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
            at java.lang.Thread.run(Unknown Source)
    ERROR: Error starting file:/C:/Java/Tools/Spring/Roo/spring-roo-1.1.5/bundle/org.springframework.roo.addon.dbre-1.1.5.RE
    LEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.dbre [10]:
    Unable to resolve 10.0: missing requirement [10.0] package; (package=javax.xml.parsers))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.dbre [10]: Unable to r
    esolve 10.0: missing requirement [10.0] package; (package=javax.xml.parsers)
            at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
            at org.apache.felix.framework.Felix.startBundle(Felix.java:1719)
            at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148)
            at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
            at java.lang.Thread.run(Unknown Source)
    ERROR: Error starting file:/C:/Java/Tools/Spring/Roo/spring-roo-1.1.5/bundle/org.springframework.roo.addon.dod-1.1.5.REL
    EASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.dod [11]: Un
    able to resolve 11.0: missing requirement [11.0] package; (&(package=org.springframework.roo.addon.configurable)(version
    >=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 8.0: missing requirement [8.0] package; (&(package=org.spring
    framework.roo.classpath)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 36.0: missing requirement [36
    .0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to
    resolve 39.0: missing requirement [39.0] package; (&(package=org.springframework.roo.support.ant)(version>=1.1.0)(!(vers
    ion>=2.0.0))) [caused by: Unable to resolve 52.0: missing requirement [52.0] package; (package=javax.xml.namespace)]]]])
    
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.dod [11]: Unable to re
    solve 11.0: missing requirement [11.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.1.0)(!
    (version>=2.0.0))) [caused by: Unable to resolve 8.0: missing requirement [8.0] package; (&(package=org.springframework.
    roo.classpath)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 36.0: missing requirement [36.0] packag
    e; (&(package=org.springframework.roo.file.monitor)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 39
    .0: missing requirement [39.0] package; (&(package=org.springframework.roo.support.ant)(version>=1.1.0)(!(version>=2.0.0
    ))) [caused by: Unable to resolve 52.0: missing requirement [52.0] package; (package=javax.xml.namespace)]]]]
            at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
            at org.apache.felix.framework.Felix.startBundle(Felix.java:1719)
            at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148)
            at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
            at java.lang.Thread.run(Unknown Source)
    ERROR: Error starting file:/C:/Java/Tools/Spring/Roo/spring-roo-1.1.5/bundle/org.springframework.roo.addon.email-1.1.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.e
    
    . . . and so on for each jar in the bundle directory

  • #2
    Are you running JDK 7 with Roo 1.1.5?

    Comment


    • #3
      Thanks Alan,
      Yes, jre 7, jdk 7, roo 1.1.5. It looks like STS 2.8.0 use different runtime enironment than machine's default jre 7.
      I've used sdk 1.6.0_29 using lockal jre, and Roo 1.1.5 works.
      So, the question is whether it's bug in jre7 or Roo 1.1.5. Either way, it should be noted in "known issues" with distribution of Roo.
      thanks again.
      Last edited by bogdan10; Nov 27th, 2011, 07:31 PM.

      Comment


      • #4
        The Apache Felix versions used in 1.1.5 are not compatible with JDK 7. Either use 1.6 with Roo 1.1.5 or upgrade to 1.2.0.RC1. The Felix dependencies were upgraded for 1.2.0.M1

        Comment


        • #5
          Thanks, this helps.

          Comment

          Working...
          X