Announcement Announcement Module
Collapse
No announcement yet.
entity jpa command fail Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • entity jpa command fail

    Hi all,
    i'm studyng Spring Roo and i'm following the official tutorial: http://static.springsource.org/sprin...beginning.html

    I have a problem with 'entity jpa' command:

    Code:
    roo> project --topLevelPackage test
    Created ROOT\pom.xml
    Created SRC_MAIN_JAVA
    Created SRC_MAIN_RESOURCES
    Created SRC_TEST_JAVA
    Created SRC_TEST_RESOURCES
    Created SRC_MAIN_WEBAPP
    Created SRC_MAIN_RESOURCES\META-INF\spring
    Created SRC_MAIN_RESOURCES\log4j.properties
    Created SRC_MAIN_RESOURCES\META-INF\spring\applicationContext.xml
    test roo> jpa setup --provider HIBERNATE --database HYPERSONIC_IN_MEMORY
    Created SRC_MAIN_RESOURCES\META-INF\spring\database.properties
    Updated ROOT\pom.xml [added dependencies org.hsqldb:hsqldb:1.8.0.10, org.hibernate:hibernate-core:3.6.7.Final, org.hibernate:hibernate-entitymanager:3.6.7.Final, org.hibernate.javax.
    1.Final, org.hibernate:hibernate-validator:4.2.0.Final, javax.validation:validation-api:1.0.0.GA, cglib:cglib-nodep:2.2.2, javax.transaction:jta:1.1, org.springframework:spring-jdbc:
    :spring-orm:${spring.version}, commons-pool:commons-pool:1.5.4, commons-dbcp:commons-dbcp:1.3; added repository https://repository.jboss.org/nexus/content/repositories/releases]
    Updated SRC_MAIN_RESOURCES\META-INF\spring\applicationContext.xml
    Created SRC_MAIN_RESOURCES\META-INF\persistence.xml
    test roo> entity jpa --class HelloWorld --testAutomatically
    Option '' is not available for this command. Use tab assist or the "help" command to see the legal options
    ~.HelloWorld roo>
    where am i wrong?

    thanks!

  • #2
    If you're using 1.2.0.M1 or earlier, then 'entity jpa' is not available - just 'entity' . The new command will be available in 1.2.0.RC1 or nightly snapshots
    Alan

    Comment


    • #3
      Thank you very much Alan! (i'm using 1.2.0.M1 version)

      Comment

      Working...
      X