Announcement Announcement Module
Collapse
No announcement yet.
Missing com.googlecode.gwt.inject:gin:jar:1.5 for GWT, BUG? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Missing com.googlecode.gwt.inject:gin:jar:1.5 for GWT, BUG?

    Not sure if anyone else had the same problem. I got missing dependency error when building my first roo project following the tutorial.
    'gwt setup' adds 'com.googlecode.gwt.inject:gin:jar:1.5' in pom.xml but it cannot be found in any mvn repository.
    I tried Roo 1.1.5 and 1.2. Both gave me the same error for building the project.
    I did some search and changed 'com.googlecode.gwt.inject:gin:jar:1.5' to 'com.google.gwt.inject:gin:jar:1.5.0'. Problem solved!
    If you got the same problem, just find the following codes in pom.xml
    HTML Code:
    <dependency>
     <groupId>com.googlecode.gwt.inject</groupId>
    <artifactId>gin</artifactId>
    <version>1.5</version>
    <classifier/>
    </dependency>
    and change it to
    HTML Code:
    <dependency>
     <groupId>com.google.gwt.inject</groupId>
    <artifactId>gin</artifactId>
    <version>1.5.0</version>
    <classifier/>
    </dependency>

  • #2
    wow, thanks for this! Just saved me a ton of time.

    Comment


    • #3
      Thanks for this information. I changed the coordinates of the dependency in https://jira.springsource.org/browse/ROO-2917.
      Alan

      Comment


      • #4
        Thanks Alan.

        Comment


        • #5
          good, it's work ,thx

          Comment


          • #6
            Hello!
            I still have problems building the project. Tried the google tutorial, too.
            Neither 1.5 nor 1.5.0 can be found.

            I am using STS2.9.0M1 + Eclipse Plugin (Maven 3.0.3, Roo 1.1.5, GWT 2.4.0).

            Any help is greatly appreciated as I am completely new to Maven & Roo.

            Comment


            • #7
              becks, check that you changed the groupId from com.googlecode.gwt.inject to com.google.gwt.inject

              Comment


              • #8

                More coffee! MOAR!

                Thanks a lot, grahamawr!
                I only focused on 1.5 vs. 1.5.0 because the rest looked somewhat identically.
                I'll copy&paste next time, I promise.
                Once again, thanks!

                Comment


                • #9
                  Thanks for the Info, i was having this problem with the example of the Spring Roo Book.

                  Comment


                  • #10
                    Worked perfect. thanks

                    Comment

                    Working...
                    X