Announcement Announcement Module
Collapse
No announcement yet.
Why are my finders disappearing? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Why are my finders disappearing?

    Seems like one time in four or so that I do an incremental database reverse-engineer, a couple of my entities lose their custom finders, and nothing I seem to do can make Roo re-generate them.

    My annotation for one of the entities in question is:

    @RooEntity(table = "workflow_step", schema = "myDb", finders = { "findWorkflowStepsByWorkflowId" })

    That finders field ought to trigger the generation of a _Roo_Finder.aj file, right? But it doesn't. Removing it and putting it back doesn't kick Roo over about it either. I tried deleting the .java entirely and rebuilding it, and there was still no joy.

  • #2
    Oop. Spoke too soon. When I closed and re-opened the Roo console, it did a whole bunch of work and barfed out the missing files.

    Is there any way to make its "oh hey I'm roo let me do my thing" function happen without relaunching the console?

    Comment

    Working...
    X