Announcement Announcement Module
Collapse
No announcement yet.
Roo + GWT (2) Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Roo + GWT (2)

    Hi,
    I am using STS 2.7.2 and have installed google web toolkit 2.4 and facing POM dependency resolution issues when trying to create a Roo+GWT application.

    After running "persistence setup --provider DATANUCLEUS --database HYPERSONIC_IN_MEMORY". Roo updates POMfile and one of the dependency jars is missing. I get missing artifact javax.jdo:jdo2-api:jar:2.3-ec:compile error in pom file. All the repositories I know only have 2.3-eb version. Where do I get 2.3-ec version or how do I resolve this?

    Similarly after running "web gwt setup", Roos creates scaffolding classes and updates many files. In the pom file, depency for com.googlecode.gwt.inject:gin:jar:1.5:compile is added. however I could not find version 1.5 in any repository.

    I have downloaded gin.jar version 1.5 from web and made pom load from local repository. This compiled the project. However I get comiple errors in Roo created resources. Primarily @Inject annotation remains unresolved.

    I wonder how to make it work.

  • #2
    Hi,

    Did I miss any step? Did anyone face this scenario before? Can Anyone help?

    Comment


    • #3
      I have post a solution here:
      http://forum.springsource.org/showth....5-for-GWT-BUG

      Hope it works for you.

      Comment


      • #4
        Hi Segg, Appreciate the info.

        Comment

        Working...
        X