Announcement Announcement Module
Collapse
No announcement yet.
issue with neo4j addon for Roo Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • issue with neo4j addon for Roo

    Hi,

    I am unable to install the addon to integrate roo project with neo4j. When I run:

    Code:
    roo> addon search graph
    Successfully downloaded Roo add-on Data
    1 found, sorted by rank; T = trusted developer; R = Roo 1.1 compatible
    ID T R DESCRIPTION -------------------------------------------------------------
    01 Y Y 1.1.0.RELEASE Roo Addon for Graph Persistence using Spring-Data-Graph
    --------------------------------------------------------------------------------
    [HINT] use 'addon info id --searchResultId ..' to see details about a search result
    [HINT] use 'addon install id --searchResultId ..' to install a specific search result, or
    [HINT] use 'addon install bundle --bundleSymbolicName TAB' to install a specific add-on version
    roo> addon install id --searchResultId 01
    roo> Unsatisfied requirement(s):
    ---------------------------
       (&(package=javax.annotation))
          org-springframework-datastore-neo4j-roo-addon
    
    roo>
    Does anyone understand what the error means?

    Thanks,
    Radim

  • #2
    I met up with the guys from Neo4J at SpringOne and agreed to make the add-on a core part of Roo for the 1.2.0.RELEASE. We utilized Spring Data JPA and Spring Data Mongo for JPA and Mongo repositories support respectively in 1.2.M1 and it should be a straightforward exercise to model a new Neo4J add-on based on these. So please wait for a few weeks.
    Alan

    Comment


    • #3
      Thanks Alan,

      I'm starting a new project and would really like to go the Neo4J-SpringData route meanwhile if I start development with in memory Hypersonic DB (persistent) Can I then migrate that easily to the new add on?

      Ritesh

      Comment


      • #4
        I am there too. Just waiting it out. I also tried the Grails plugin, but having issues with Grails 2.0

        I think we are a little early on the Neo4j and Roo and Grails latest versions which aren't GA yet. So the addons and plugins won't get done till the other stuff has been completed.

        Mark

        Comment


        • #5
          issue with neo4j addon for Roo

          im having the same issu with the addon
          here is the problem:

          roo> addon install id --searchResultId 01
          roo> Unsatisfied requirement(s):
          ---------------------------
          (&(package=org.springframework.roo.support.style)( version>=1.1.0))
          org-springframework-datastore-neo4j-roo-addon
          (&(package=org.springframework.roo.addon.entity)(v ersion>=1.1.0))
          org-springframework-datastore-neo4j-roo-addon

          roo>
          roo>

          is there any solution yet ?

          Comment


          • #6
            I too am having the same 'Unsatisfied requirement(s):' problem while following the examples in Long&Mayzak's 'Getting Started with Roo' book. I've installed spring-roo-1.2.1.RELEASE and sts-2.9.1.RELEASE but apparently the Neo4J addon is not compatible.

            It's just a learning experience for me, so I'll skip this section of the book for now. Hope to see an update soon; I'll subscribe to this thread

            Comment


            • #7
              The current Neo4J add-on is not compatible with Roo 1.2.x, however as I mentioned above a new one will be developed using the latest Spring Data Neo support.

              Comment


              • #8
                That would be great. Looking forward to try out this add on with 1.2.x

                Comment


                • #9
                  I am a newbie. I even tried with Roo-1.1 as the 'Getting started book was using 1.1.3', I still could not download
                  Pasting the output from ROO console
                  Code:
                  roo> addon search graph
                  0 found, sorted by rank; T = trusted developer; R = Roo 1.1 compatible
                  ID T R DESCRIPTION -------------------------------------------------------------
                  --------------------------------------------------------------------------------

                  Comment

                  Working...
                  X