Announcement Announcement Module
Collapse
No announcement yet.
STS abnormally slow, GWT add-on questions Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS abnormally slow, GWT add-on questions

    Hi,

    as stated in a previous post, I'm quite new with SpringSource and Roo. I'm a Junior JavaEE dev.

    This is not really a problem, just to see if anyone experience the same frustration using STS and Roo.

    My setup:
    - Windows 7 64 bit (clean install)
    - STS 2.8.0
    - Roo 1.1.5.RELEASE [rev d3a68c3]
    - JDK 1.7.0_01 64 bit

    - Core2Duo [email protected], 4go RAM

    First, I'm very impressed by Roo, the code generation and everything is really suit. But I'm having some "problems".

    I have the feeling that my computer is an old peace of crap. I'm toying around with Roo, making some basic projects just to see how everything is working, having the springsource and roo doc alongside. And every action is taking so long I even though Eclipse wasn't responding anymore.

    My final goal is to make Spring and GWT work together and having Roo to generate all CRUD things. So here I am, making a brand new Roo project. Setup the persistence and making a basic entity. That's all!

    Now, eclipse already takes some time to build the workspace but nothing big. After this, I want to incorporate GWT and thus I type "gwt setup" in the Roo shell. It takes some time to generate all the classes and everything but it's ok, no complains.

    But now it's when the fun starts. Every action just freezes my computer. Opening Eclipse takes about 5 minutes. Every change in the project properties takes a lot more. The "building workspace" is my nightmare.

    The only thing I managed to get so far, after one day of tests and a lot of waiting is to try the Roo default MVC web generated pages and to test it in the default tomcat 7 server. For that purpose I had to change the timeout from 120seconds to 360 just to be able to launch the server.

    With, GWT, I got the "perform package" working, took some time, but I'm stuck at the "Loading..." page when going in the tomcat server. I've tried the GWT development mode, same thing. And like I said, every action takes like forever.

    The most advanced stage was to get an error from the GWT Development mode: http://pastebin.com/eGGzGkcU

    Eclipse regularly hangs up too.

    So I'm wondering what I'm doing wrong!

    * Is it because I'm using the latest JDK 1.7 ? Do I have to go back to 1.6?
    * Is Roo taking so much time with everything? It's a cool feature but I feel more like I'm waiting more than working.

    If anyone is kind enough to guide this poor lamb, that would be wonderful!

    Similar topic:
    http://forum.springsource.org/showth...highlight=slow

  • #2
    Same questions again, I tried to go back to the JDK 1.6 without success. I still can't get the Roo GWT to work.

    I saw an article stating that Roo 1.2 has really improved the GWT module, So I downloaded a nightly build (all of them) and, I can't get it to work, whatever command just complains about the "\" of the working directory.

    I know I surely ask dumb questions, but it would be very kind if anyone could just answer if it's normal to have a very hard time with Roo or if I missed something.

    As for now, I gave up to the GWT ui generation and I'll just build the entities with roo.

    Comment


    • #3
      Have you checked your ram usage? If you're maxing out it will slow to a crawl and it's faster to just kill it and reopen STS. If that's the case I found -Xmx840m to be the highest I could set it. To use more ram you have to Install STS on top of Eclipse 64bit.
      Personally I have everything generated for about 60 tables, and the AspectJ builder is killing me. Not sure on the time difference, if I hadn't Refactored->Push-in, but right now AspectJ takes about 15 minutes, so make sure Build Auto is off. I plan on removing Roo support as soon as I'm sure everything has been generated properly and I think that will get rid of the build time problems.
      I'm also using JDK 1.7. I have Eclipse running off the 64bit and my project using the 32bit since I read somewhere GWT needs it. I'm running the Roo 1.2.0.M1 since it uses GWT 2.4 and Roo 1.1.5 uses GWT 2.2.

      On a side note if you use 1.2.0.M1/GWT 2.4 you'll need to change your pom.xml
      replace the gwt-servlet dependency with:

      Code:
       
      <dependency>
         <groupId>com.google.web.bindery</groupId>
         <artifactId>requestfactory-server</artifactId>
         <version>2.4.0</version>
       </dependency>
       <dependency>
         <groupId>com.google.web.bindery</groupId>
         <artifactId>requestfactory-apt</artifactId>
         <version>2.4.0</version>
       </dependency>

      Comment


      • #4
        thanks for your reply!

        I tried the nightly from the 2 and 3 november without success. I've had enough with Roo, now I'm learning Grails, more mature. And I'm also leaving GWT for the moment. I can't do everything I wanted as I really must move forward.

        Comment

        Working...
        X