Announcement Announcement Module
Collapse
No announcement yet.
Will Roo 1.2Release support 1.5 source generation in any shape or form? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Will Roo 1.2Release support 1.5 source generation in any shape or form?

    To the Roo development team: I have understood that Roo will default to minimal jdk 1.6 support at some future point, now when the jdk 1.7 is the current jdk.
    Right now Roo 1.2M1 still work fine with running on jdk 1.5 and generates 1.5 compliant source code too. Will Roo 1.2Release work with java 1.5 code generation as well and it is at some point after that 1.6 will become the version of java source that Roo generates and supports?

  • #2
    JDK 1.5 code compliance in Roo 1.2.x is not guaranteed any more. While most code will still compile there are some cases where 1.6 is required as a minimum already (ie if you choose to use Spring Data JPA repositories).

    Comment


    • #3
      Originally posted by Stefan Schmidt View Post
      JDK 1.5 code compliance in Roo 1.2.x is not guaranteed any more [...]
      It's going to be a problem for WebSphere 6.1.

      Comment

      Working...
      X