Announcement Announcement Module
No announcement yet.
Some Spring ROO 1.2 M1 GWT addon feedback (with GWT 2.4) Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Some Spring ROO 1.2 M1 GWT addon feedback (with GWT 2.4)

    First of all, thanks for the release guys. I have the feeling that from all the versions of ROO GWT addon, this is the first I would trust to go in production with. There are some small issues though which I will lay down below:

    1. I love that I can only generate the RequestFactory support and leave scaffolding out :-D
    2. If you leave scaffolding out like this:

    web gwt setup
    web gwt proxy all --package ~.client.proxy
    web gwt request all --package ~.client.request

    Then I would suppose you should be able to start re-using the generated RequestFactory code immediately. However this is not the case because the generated code misses the following classes in order to be fully functional:


    These are generated only by the scaffold command. If you could generate these under the "web gwt request all" then one would be able immediately to create the app factory and start making request factory calls from it's own views. I can't tell how awesome this would be.

    3. GWT 2.4 scaffolded app doesn't work failing with:

    Sep 15, 2011 2:20:12 PM stFactoryServlet doPost
    SEVERE: Unexpected error
    java.lang.RuntimeException: The RequestFactory ValidationTool must be run for the ro.adaptiv.whatnot.client.request.AppRequestFactor y RequestFactory type

    See additional info here:


  • #2
    Hey Dorel, thanks for the feedback! Keep it coming You make a really good point re. the custom servlet and decorator, I will fix that up and update this thread when the changes are in a snapshot. With regards to the ValidationTool, a maven-exec plugin should've been added to the pom to automate this...


    • #3
      Any progress on upgrading to 2.4?!!! There is an important bug fix related to editable ListEditor that made it to 2.4 and I desperately need to utilize it, if you have a work around it would be greatly appreciated.



      • #4
        i don't know!


        • #5
          Issues with GWT and Spring ROO

          Im having a problem that i think is related to this same deal:

          Im folowing the instructions on the main Spring Roo webpage:

          mkdir hello
          cd hello
          roo> hint
          roo> project --topLevelPackage
          roo> jpa setup --provider HIBERNATE --database HYPERSONIC_IN_MEMORY
          roo> entity jpa --class ~.Timer --testAutomatically
          roo> field string --fieldName message --notNull
          roo> hint web mvc
          roo> web mvc setup
          roo> web mvc all --package ~.web
          roo> selenium test --controller ~.web.TimerController
          roo> web gwt setup
          roo> perform tests
          roo> quit

          However when i get to the point where i type "perform tests" maven fails to execute the goal, the error that i get is:

          error: Could not find root type actory

          I guess it has something to do with Roo not creating the full stack of classes needed to run the tests, but following the "hello world" instructions on the projects main webpage shouldnt lead to this kind of errors...


          • #6
            I have the same exact issue as andresneva:

            error: Could not find root type actory

            I was following the section named "First Project - Roo Standalone" at My tool versions are:

            Maven 3.0.4
            Spring Roo GA release: 1.2.1



            • #7
              You can exit roo, stay in the same directory as your test project and run mvn -e clean install outside of roo. This gives you a stack trace, and then you see org.apache.maven.lifecycle.LifecycleExecutionExcep tion, and a little farther down, you see org.apache.maven.plugin.MojoExecutionException. At the bottom of the roo shell, you see a reference/url about this exception.

              Bottom line is that the problem seems to be caused by a missing proxy configuration setting in .m2/settings.xml.


              • #8
                I don't see any MMojoExecutionException or URL - just

                # mvn clean install    
                [INFO] Copying 4 resources
                [INFO] [compiler:compile {execution: default-compile}]
                [INFO] Nothing to compile - all classes are up to date
                [INFO] [exec:exec {execution: default}]
                error: Could not find root type
                1 error
                [INFO] ------------------------------------------------------------------------
                [ERROR] BUILD ERROR
                [INFO] ------------------------------------------------------------------------
                [INFO] Command execution failed.
                 # find . -name '*.java' -o -name '*.class'


                • #9
                  Same Error

                  I am also getting same error.

                  [INFO] Scanning for projects...
                  [INFO] ------------------------------------------------------------------------
                  [INFO] Building pizzaShop 0.1.0.BUILD-SNAPSHOT
                  [INFO] ------------------------------------------------------------------------
                  [INFO] --- aspectj-maven-plugin:1.2:compile (default) @ pizzaShop ---
                  [WARNING] advice defined in org.springframework.scheduling.aspectj.AbstractAsyncExecutionAspect has not been applied [Xlint:adviceDidNotMatch]
                  [WARNING] advice defined in org.springframework.mock.staticmock.AnnotationDrivenStaticEntityMockingControl has not been applied [Xlint:adviceDidNotMatch]
                  [WARNING] advice defined in org.springframework.mock.staticmock.AbstractMethodMockingControl has not been applied [Xlint:adviceDidNotMatch]
                  [INFO] --- maven-resources-plugin:2.5:resources (default-resources) @ pizzaShop ---
                  [debug] execute contextualize
                  [INFO] Using 'UTF-8' encoding to copy filtered resources.
                  [INFO] Copying 4 resources
                  [INFO] --- maven-compiler-plugin:2.3.2:compile (default-compile) @ pizzaShop ---
                  [INFO] Nothing to compile - all classes are up to date
                  [INFO] --- exec-maven-plugin:1.2:exec (default) @ pizzaShop ---
                  error: Could not find root type
                  1 error
                  [INFO] ------------------------------------------------------------------------
                  [INFO] BUILD FAILURE
                  [INFO] ------------------------------------------------------------------------
                  [INFO] Total time: 7.086s
                  [INFO] Finished at: Thu Apr 19 14:46:35 IST 2012
                  [INFO] Final Memory: 7M/16M
                  [INFO] ------------------------------------------------------------------------
                  [ERROR] Failed to execute goal org.codehaus.mojo:exec-maven-plugin:1.2:exec (default) on project pizzaShop: Command execution failed. Process exited with an error: -1(Exit value: -1) -> [Help 1]
                  [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
                  [ERROR] Re-run Maven using the -X switch to enable full debug logging.
                  [ERROR] For more information about the errors and possible solutions, please read the following articles:
                  [ERROR] [Help 1]


                  • #10
                    I have been struggling with similar issues and then some. I finally succeeded to make Maven, 2.4, validation and RF work all together. Here's the details in a separate thread. Hope it helps