Announcement Announcement Module
Collapse
No announcement yet.
Spring Roo & Java 1.7 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Roo & Java 1.7

    I've tried to upgrade my Roo project to the latest JDK version but I'm getting several errors. All of the same kind:
    Code:
    declare @type is only supported at Java 5 compliance level or above
    Something related to the AspectJ it seems but the project won't compile. Any workaround or idea?

  • #2
    If you have the value of "1.7" in the <source> and <target> values in the <configuration> section of the aspectj-maven-plugin, then change it to 1.6. When a new Roo project is created these values get the Java version that Roo is started with. It appears the plugin cannot handle JDK 7 yet. I will follow this up with the AspectJ guys.
    Last edited by Alan Stewart; Aug 6th, 2011, 05:29 AM.

    Comment

    Working...
    X