Announcement Announcement Module
Collapse
No announcement yet.
Project broken - cannot continue ROO development: Index: 0, Size: 0 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Project broken - cannot continue ROO development: Index: 0, Size: 0

    Same as https://jira.springsource.org/browse/ROO-2369 but with ROO versions 1.1.4, 1.1.5 and 1.2
    It only writes "Index: 0, Size: 0" into the console and does not do anything anymore.

    I tried a complete clean, reset internal caches, refresh, and fresh checkout of an old revision of our project, where ROO definitly worked.
    The only effect is that I sometimes get different StackOverflowErrors in the roo shell and then, after changing an entity, again an IndexOutOfBoundsException: Index: 0, Size: 0
    As you see on this screenshots:
    http://geomobile-integration.de/roo_stack_overflow.jpg
    http://geomobile-integration.de/roo_...overflow_2.jpg

    The HEAD of our project runs perfect, but we cannot continue development!
    Any ideas are very appreciated as we are now stuck in the most important project of our young company.

    And here are the screenshots for the "Index 0" error for the mentioned versions:
    http://geomobile-integration.de/roo114.jpg
    http://geomobile-integration.de/roo115.jpg
    Last edited by ulimann; Jul 28th, 2011, 12:54 PM. Reason: another StackOverflowError

  • #2
    After an other day of research I fixed the problem.
    A public helper method in an abstract entity named "setWhatever()" breaks roo. After renaming it to "addWhatever()" roo continued working.
    I remembered that an entity field named "isAdmin" caused similar problems earlier in our project.
    So we continue with roo and the rule "don't let any field or method names in roo entities start with "set", "get" or "is".

    cheers ulimann

    Comment


    • #3
      This seems a bit strange. Can you please attach your Java class that caused the issue, and any child classes? I would like to attempt to reproduce the issue.

      Comment


      • #4
        Just from yesterday I have the same problem. First start with a "Index: 0, Size: 0", than sometimes write StackOverflowError with the same evidences that have ulimann... My ROO version is: 1.2.0.M1 [rev 1fa252f]

        My project has about 12 entities. This problem completely freeze my customization: I cannot continue ROO development... :-((

        Please let me know something about...

        Comment


        • #5
          Use 1.2.0.RELEASE

          Comment


          • #6
            OK! Thank you! I'll migrate as soon as possible from 1.2.0.M1 to 1.2.0.RELEASE .

            Best Regards,
            Paolo Del Signore

            Comment

            Working...
            X