Announcement Announcement Module
Collapse
No announcement yet.
Unable to open "Roo shel" in STS Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to open "Roo shel" in STS

    Hi,

    When I import the project in STS and try to open roo shell, shell will not respond.
    I copied a file "com.springsource.sts.roo.core.prefs" in .settings to open the roo shell.

    Is there any other way or configuration to do this at the time of project creation.

    Thanks & Regards,
    Rohit

  • #2
    You need to define a valid Roo installation in STS: Preferences > Spring > Spring Roo ...

    Comment


    • #3
      Hi,
      I have a valid roo installation in sts 2.7.0. When I try to open the roo shell for the pizza project it never finish.
      Regards
      Gunnar

      Comment


      • #4
        1.1.4 works OK in STS 2.7.0 and 1.1.5 will be part of 2.7.1

        Comment


        • #5
          I use 1.1.4 but can't start the roo shell. I've tried creating a new roo project and also start the roo shell for a roo project but same result.
          The shell is never started.

          This is the content of the .log file
          !SESSION 2011-07-10 21:23:47.667 -----------------------------------------------
          eclipse.buildId=2.7.0.201107041000-RELEASE
          java.version=1.6.0_18
          java.vendor=Sun Microsystems Inc.
          BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=sv_SE
          Framework arguments: -product com.springsource.sts.ide
          Command-line arguments: -os win32 -ws win32 -arch x86_64 -product com.springsource.sts.ide

          !ENTRY org.eclipse.ui 4 4 2011-07-10 21:23:56.870
          !MESSAGE Unable to create menu item "ReloadDependencies", command "org.eclipse.wst.xml.ui.reload.dependecies" not defined

          Gunnar
          Last edited by gunnarbo; Jul 10th, 2011, 03:28 PM. Reason: added log file

          Comment


          • #6
            With STS 2.7.0 you will need to run the Roo shell (of any version you like) from the operating system's command prompt.

            In the next day or so, STS 2.7.1 will be released with Roo 1.1.5 integrated into it.

            Sorry for the confusion and inconvenience.

            Comment


            • #7
              Okay, Thanks.
              Gunnar

              Comment


              • #8
                Hi, I've updated STS to 2.7.1 and Roo to 1.1.5.
                Now I get "No valid Spring Roo installation..."
                I've added roo support and it works outside sts.
                I'm using a Swedish Windows 7. Can that be a problem?
                Gunnar

                Comment


                • #9
                  You should raise this on the STS forum. It works for English.

                  Comment


                  • #10
                    I just installed STS 2.7.1 with Roo 1.1.5Release under jdk 6 update 26 on Windows 7 and the Roo shell never loads, both when importing existing Roo projects and when creating new.

                    I'm fresh to Windows 7. Where do I start? Is it my set up or Roo on Windows 7 the more likely culprit?

                    Comment


                    • #11
                      We have tested Roo 1.1.5 in a Windows 7 VM without issues and it appears other Roo users also don't have issues, so there is a good chance something is special in your setup. Are you running some sort of anti virus that could block Roo, or are you behind a firewall?

                      Comment


                      • #12
                        just create the new project from the roo shell(command prompt). you will find the "com.springsource.sts.roo.core.prefs" file in .settings folder, just copy and paste this file in .settings folder of your project created in STS.

                        Comment


                        • #13
                          All I did to solve this was to change the setting of the Roo 1.1.5 folder to not be write-protected. I'm not sure why it was installed that way, but even if the ACE is set to have folders write-protected the installer should make sure the Roo folder is not. At the very least it should note the user, there was a problem setting up the Roo folder properly.

                          Comment


                          • #14
                            I changed the properties of the Roo1.1.5 folder to not be write protected and that solved the problem. I remember similar, but concerning a different invisible folder inside the user folder, problems on Mac OS X. I hope this is all in the troubleshooting section of the manual for the newbies and others.

                            Comment


                            • #15
                              HI,
                              I'm the owner of the folder. I installed roo in a bin directory in my own user.
                              I can also run roo from the command prompt, but STS complains about no valid roo configuration.
                              /Gunnar

                              Comment

                              Working...
                              X