Announcement Announcement Module
Collapse
No announcement yet.
ROO 1.1.3, I cannot get the JSON results Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • ROO 1.1.3, I cannot get the JSON results

    I did as what the doc said, defined all of my entities, and executed
    Code:
    controller all
    , and then, I realize I need JSON result, so I executed
    Code:
    json all
    , and executed command by maven (I chose the Google Appengine Datastore as my DB)
    Code:
    mvn gae:run
    when I run
    Code:
    curl -i -H "Accept: application/json" http://localhost:8080/petclinic/owners
    , I still get the html response, not JSON.

    I reviewed the source, it did generate the *Controller_Roo_Controller_Json.aj files. And I rebuilt the web app, but I still cannot get the JSON response, but HTML response. What did I wrong? Did I miss some step? It cannot get the correct JSON response if I use GAE?

  • #2
    OK, it works now

    I regenerated the source by run the log.roo script, and it works well now.

    I have no idea why it works well now, maybe I modified the source mannually before, but the roo shell was running and it updated the source everytime when I modified the java file. It must be something hidden bug hard to be reproduced.

    Anyway, regenerate the source is not so painful, thank roo a lot.

    Comment

    Working...
    X