Announcement Announcement Module
Collapse
No announcement yet.
Deploying Roo application on Weblogic 10.3.2 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Deploying Roo application on Weblogic 10.3.2

    Hi,

    I'm trying to deploy ROO application on weblogic 10.3.2 server, I made a sample web application with JPA2 features

    we are actually considering ROO as the dev platform for our new applciation development, we have to deploy the application on webloigc server.

    please help.

    Thanks,
    Vishnu

  • #2
    Help with what? You might need to explain a little more what issues you are having.

    The only extra step I'm aware of that need to deploy a vanilla Roo app to a container like Weblogic is to wrap the war in an ear. The Maven ear plugin can do this, and with a little scope config tweaking you can have it bundle all of the dependencies inside the ear rather than the war, and generate a manifest.

    Comment


    • #3
      Hi Brad,

      Thanks for your reply ,


      Since Weblogic 10.3.2 is JEE5 compliant server, it comes pre bundled with JPA1.0 libs , when we try to deploy ROO based war( roo uses JPA2.0), it validates the persistence.xml and throws the validation errors when trying to deploy the war/ear ..

      Based on my research I have figured out following options ,
      1) Renaming the persistence.xml (didn't work)
      3)
      2) changing the version and xsd file declaration in persistence.xml (not an option for me , we have to use JPA2)
      3) removing the JPA 1.0 jar files from webloigc modules directory (it worked but leads to server wide impact on all dependent domains)

      similar issues have been observed with other JEE5 compliant app server (eg:Websphere,Jboss).

      finally I'm able to successfully deploy the roo web app on Webloigc 10.3.4 (which supports JPA2.0) bit still getting classCastExceptions when accessing the application.
      I have tried with <prefer-web-inf-classes>true</prefer-web-inf-classes> option but still getting ClassCastException related to Hibernate classes.

      I'm looking for a better solution and an alternative if we have to stick to 10.3.2 version server.

      Thanks in advance.
      Vishnu

      Comment


      • #4
        Hello vishnu , I am stuck with the same problem. We are using weblogic 10.3.3 on the production enviornment and I have used sprong roo 1.2.1 for developemnet. But it gives me JPA error (compalining about JPA2.0) when I try to deploy it on weblogic10.3.3.

        Did you ever find a solution for this problem ? Your reply here will be strongly appriciated.

        Comment

        Working...
        X