Announcement Announcement Module
Collapse
No announcement yet.
Unable to cache bundle? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to cache bundle?

    I have 1.1.3 installed, and out of nowhere AFAICT, I started getting these errors upon starting Roo at the command line. After these errors, I seem to be able to use Roo just fine. Any ideas?

    -matthew

    Code:
    C:\temp\roo>roo
    Auto-deploy install: org.osgi.framework.BundleException: Unable to cache bundle: file:/C:/java-dev/springsource/spring-roo-1.1.3.RELEASE/bundle/._jansi-1.5.jar - java.util.zip.ZipException: error in opening zip file
    Auto-deploy install: org.osgi.framework.BundleException: Unable to cache bundle: file:/C:/java-dev/springsource/spring-roo-1.1.3.RELEASE/bundle/._org.apache.felix.bundlerepository-1.6.4.jar - java.util.zip.ZipException: error in opening zip file
    Auto-deploy install: org.osgi.framework.BundleException: Unable to cache bundle: file:/C:/java-dev/springsource/spring-roo-1.1.3.RELEASE/bundle/._org.apache.felix.ipojo-1.6.8.jar - java.util.zip.ZipException: error in opening zip file
    Auto-deploy install: org.osgi.framework.BundleException: Unable to cache bundle: file:/C:/java-dev/springsource/spring-roo-1.1.3.RELEASE/bundle/._org.apache.felix.log-1.0.0.jar - java.util.zip.ZipException: error in opening zip file
    Auto-deploy install: org.osgi.framework.BundleException: Unable to cache bundle: file:/C:/java-dev/springsource/spring-roo-1.1.3.RELEASE/bundle/._org.apache.felix.scr-1.6.0.jar - java.util.zip.ZipException: error in opening zip file
    Auto-deploy install: org.osgi.framework.BundleException: Unable to cache bundle: file:/C:/java-dev/springsource/spring-roo-1.1.3.RELEASE/bundle/._org.apache.felix.shell-1.4.2.jar - java.util.zip.ZipException: error in opening zip file
    Auto-deploy install: org.osgi.framework.BundleException: Unable to cache bundle: file:/C:/java-dev/springsource/spring-roo-1.1.3.RELEASE/bundle/._org.springframework.roo.addon.backup-1.1.3.RELEASE.jar - java.util.zip.ZipException: error in opening zip file
    Auto-deploy install: org.osgi.framework.BundleException: Unable to cache bundle: file:/C:/java-dev/springsource/spring-roo-1.1.3.RELEASE/bundle/._org.springframework.roo.addon.configurable-1.1.3.RELEASE.jar - java.util.zip.ZipException: error in opening zip file
    Auto-deploy install: org.osgi.framework.BundleException: Unable to cache bundle: file:/C:/java-dev/springsource/spring-roo-1.1.3.RELEASE/bundle/._org.springframework.roo.addon.creator-1.1.3.RELEASE.jar - java.util.zip.ZipException: error in opening zip file
    ...
    Auto-deploy install: org.osgi.framework.BundleException: Unable to cache bundle: file:/C:/java-dev/springsource/spring-roo-1.1.3.RELEASE/bundle/._org.springframework.uaa.client-1.0.2.RELEASE.jar - java.util.zip.ZipException: error in opening zip file
        ____  ____  ____
       / __ \/ __ \/ __ \
      / /_/ / / / / / / /
     / _, _/ /_/ / /_/ /
    /_/ |_|\____/\____/    1.1.3.RELEASE [rev 4404ffb]
    
    
    Welcome to Spring Roo. For assistance press TAB or type "hint" then hit ENTER.
    roo> Downloaded 0% of roobot.xml.zipDownloaded 0% of roobot.xml.zipDownloaded 100% of roobot.xml.zipDownloaded 100% of roobot.xml.zipDownloaded 100% of roobot.xml.zipDownloaded 100% of roobot.xml.zipDownloaded 100% of roobot.xml.zipDownloaded 100% of roobot.xml.zipDownloaded 100% of r
    0 upgrades available (plus 29 upgrades not visible due to your version stability setting of RELEASE)
    roo> Downloaded 100% of roobot.xml.zipDownloaded 100% of roobot.xml.zipDownloaded 100% of roobot.xml.zipDownloaded 100% of roobot.xml.zipDownloaded 100% of roobot.xml.zipDownloaded 100% of roobot.xml.zipDownloaded 100% of roobot.xml.zipDownloaded 100% of roobot.xml.zip
    roo>

  • #2
    I have the same problem!!!!!

    Comment


    • #3
      https://jira.springsource.org/browse/ROO-2402

      Comment


      • #4
        I've seen this happen with the Roo 1.1.3 that comes bundled with STS, in which case please try the standalone Roo distribution.

        Comment


        • #5
          yup...that fixes it...thanks

          Comment


          • #6
            Would you also please try the latest 1.1.4 build snapshot release in STS?

            Comment


            • #7
              I did.....STS 2.6.1....not a problem

              Comment

              Working...
              X