Announcement Announcement Module
Collapse
No announcement yet.
install view command broken? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • install view command broken?

    I'm getting the following error when trying to install a new view:

    roo> web mvc install view --path /register --title Register --viewName registrationForm
    Created SRC_MAIN_WEBAPP\WEB-INF\views\register
    Created SRC_MAIN_WEBAPP\WEB-INF\views\register\registrationform.jspx
    Updated SRC_MAIN_WEBAPP\WEB-INF\i18n\application.properties
    Updated SRC_MAIN_WEBAPP\WEB-INF\views\menu.jspx
    Created SRC_MAIN_WEBAPP\WEB-INF\views\register\views.xml
    [Fatal Error] :90:6: The string "--" is not permitted within comments.
    Undo manage SRC_MAIN_WEBAPP\WEB-INF\spring\webmvc-config.xml
    Undo create SRC_MAIN_WEBAPP\WEB-INF\views\register\views.xml
    Undo manage SRC_MAIN_WEBAPP\WEB-INF\views\menu.jspx
    Undo manage SRC_MAIN_WEBAPP\WEB-INF\i18n\application.properties
    Undo create SRC_MAIN_WEBAPP\WEB-INF\views\register\registrationform.jspx
    Undo create SRC_MAIN_WEBAPP\WEB-INF\views\register
    The string "--" is not permitted within comments.
    roo>

    Googling seemed to suggest this might be a Xerces bug, perhaps you're using an old version?

  • #2
    Hmm, works for me:


    Code:
    ~.web roo> web mvc install view --path /register --title Register --viewName registrationForm
    6bb21ed Updated SRC_MAIN_WEBAPP/WEB-INF/i18n/application.properties
    512b51b Updated SRC_MAIN_WEBAPP/WEB-INF/i18n/application.properties
    3283179 Updated SRC_MAIN_WEBAPP/WEB-INF/views/menu.jspx
    Created SRC_MAIN_WEBAPP/WEB-INF/views/register
    d5218a0 Created SRC_MAIN_WEBAPP/WEB-INF/views/register/views.xml
    f9aba75 Created SRC_MAIN_WEBAPP/WEB-INF/views/register/registrationform.jspx
    4014676 Updated SRC_MAIN_WEBAPP/WEB-INF/spring/webmvc-config.xml
    Can you share a bit of information around your setup? (OS, Roo version, JDK, etc)

    Comment


    • #3
      I can't reproduce this with either 1.1.2, 1.1.3 or the latest 1.1.4 snapshot release using JDK 1.6.0_24. What JDK are you using?

      Comment


      • #4
        Thanks for the response. I'm running Roo 1.1.2 on Win7. I've tried this with JDK 1.6_20 and now JDK 1.6_24 and get the same error on both. I've also tried via roo.sh on Cygwin (my usual choice) and roo.bat on the command prompt.

        However, I found it works fine on one project (basic pizza shop), but not on my main project. Both are simple apps, though. Could a dependency in the app affect Roo?

        Comment


        • #5
          I will have to try this on a Windows install later tonight to verify. In the meantime can you please try the same command without the slash?:

          Code:
          roo> web mvc install view --path register --title Register --viewName registrationForm

          Comment

          Working...
          X