Announcement Announcement Module
Collapse
No announcement yet.
STS tc Server tools w/ Spring Insight Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS tc Server tools w/ Spring Insight

    With tc Server I created a server instance using the Spring Insight template. I started it up from the command-line and deployed my application, and everything works fine....Spring Insight gives me a bunch of great info about my running application.

    I installed STS tc Server tools into Eclipse 3.4. I created a Server using the server adapter for SpringSource tc Server. I pointed it at the same server instance as above, and I deployed my application. Application runs fine, but Spring Insight doesn't show any telemetry data. :-(

    I shutdown Eclipse and started the server from the command-line, and the applications deploy fine. However there still isn't telemetry data.

    I repeated this process several times. It appears that the moment I startup a tc server instance from Eclipse, Spring Insight stops working correctly.

    Has anyone run into this?

  • #2
    Hi Neyde,

    The tc-server w/insight deploys more than just the simple insight.war. It also contains instrumentation in the tomcat libdir as well as a webapps_lib directory. Have you tried the pre-packaged sts download 2.2.0?

    Comment


    • #3
      Oops, I just noticed the thread was moved here. I answered this in the tc Server General forum:

      I had the same problem. I created a new instance, which worked (and showed data). I compared the two, and this is how I solved it: in eclipse, in the context.xml for the tc Server, I added

      Code:
      <Valve className="com.springsource.metrics.collection.web .HttpRequestMetricCollectionValve" />
      
      <Loader loaderClass="com.springsource.tcserver.ltw.TomcatA spectJWeavingClassLoader"
        useSystemClassLoaderAsParent="false" />
      just before the closing </Context>. I think this "disappeared" when eclipse configured the server somehow.

      I've noticed that for changes in /Servers/ to take, I sometimes need to bring up the server config by double-clicking on the server in the Servers view, making a simple change (such as changing the port number) and saving. That seems to trigger a push of the config to the server, so you may have to do the same for your change to take.

      Comment

      Working...
      X