Announcement Announcement Module
Collapse
No announcement yet.
Insight not showing web Filter chain Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Insight not showing web Filter chain

    We're trying to get Spring Insight running, but having trouble getting more information out of it. We're using Spring 3.0.5, Insight-1.5.1.SR2, tcserver-2.6.3. Currently it shows the initial request and then a bunch of JDBC statements after that.

    For some reason it is now showing any of the servlet filters that are being run as part of the web container. (When I run Spring's Petcare application, it shows all the filters and method calls.) I know there may be some issues in our spring configuration which isn't allowing insight to get the method calls, but I'm at a loss as to why the filters aren't showing up - anyone have any ideas?
    Last edited by anztenney; Jun 29th, 2012, 11:20 AM.

  • #2
    You can try and turn some tracing on to find out why. If you add a META-INF/aop.xml file to your app you can enable verbose logging, debug etc. It will show you what aspects are registered, what classes are being considered for weaving and which one's match pointcut expressions. Not an answer to your question but might help you work it out

    Code:
    <!DOCTYPE aspectj PUBLIC "-//AspectJ//DTD//EN" "http://www.eclipse.org/aspectj/dtd/aspectj.dtd">
    <aspectj>
    	<weaver options="-verbose -showWeaveInfo -debug">
    
    	</weaver>
    </aspectj>

    Comment


    • #3
      Thank you! I was completely unfamiliar with the aop.xml, but we had one in our code base. It was experiment from several years ago that was left in and not being used. I quickly discovered we had an invalid include in this file that was limiting what was matching the pointcut expressions. After cleaning this up, everything is working as expected in Insight.

      One other note, another developer spent a couple weeks going back and forth with VMWare about this issue about 3 months ago with no success. I spent a couple days - THANK YOU!

      Comment


      • #4
        No problem, glad I could help

        Comment

        Working...
        X