Announcement Announcement Module
Collapse
No announcement yet.
JDBC Drill Down and Go to Source Options Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • JDBC Drill Down and Go to Source Options

    All,
    I have read other threads in this forum which talk about the same and but could not get a solution for this issue that I am facing and hence posting this once again.

    My Insight version is 1.0.0.M2 and I am using insight which comes bundled with STS. I am able to see trace details like the ones mentioned below in blue color (sorry could not take the screenshot) but I don't see JDBC level drill downs (as shown in demos) or 'Go to Source' towards the bottom. My OS is Ubuntu by the way.

    these are the only trace details I can see at the moment -

    Trace Detail 3:28:20 PM (535 ms)
    535 ms POST /soccer/j_spring_security_check
    Http Operation
    Label POST /soccer/j_spring_security_check
    Response Details com.springsource.insight.collection.tcserver.reque st.HttpResponseDetailsBean
    Path /soccer/j_spring_security_check
    Request Details com.springsource.insight.collection.tcserver.reque st.HttpRequestDetailsBean


    thanks
    gary

  • #2
    Hi Gary,

    First off you should be using a current version of Insight. 1.0.0.M2 is pretty old. Our current release is 1.5.0 and you can access it off springsource.org/insight
    I just updated this site to contain the newest links into the vmware.com release artifacts.

    Now onto your specific problem. What is the application you are deploying to Insight? Is it written in Spring, use Hibernate, hit JDBC? Is your JDBC driver in tomcat/lib or is it in your .war? Are you using JDNI to talk to your JDBC driver?

    This issue has come up a number of times, and we are not able to replicate it with any of our applications. If you can still do this with a modern version, I would love to get a stripped-down application which replicates the issue.

    Comment


    • #3
      hello,

      i am having similar issues i.e. not seeing any JDBC calls. by the way i feel i can answer some of your questions as it might apply to my app also

      What is the application you are deploying to Insight? Spring WS
      use Hibernate, hit JDBC? YES
      Is your JDBC driver in tomcat/lib -- YES
      Are you using JDNI to talk to your JDBC driver? YES

      in addition to the above do i need to add any other annotations ? currently i have @Service annotation to my Service Class and i am able to see the the service name and its operation

      Thanks
      DP

      Comment


      • #4
        We have discovered why JDBC is not showing up for some people. You will have this issue if AspectJ overweaving is enabled. Please check out your tc-server's bin/setenv.sh to ensure that overweaving is not enabled. (or take a look at your STS Server configuration)

        See this issue: http://issuetracker.springsource.com/browse/INSIGHT-12

        Some people DO need AspectJ overweaving enabled, and this has been fixed in Insight 1.5.1, which will be available within the next few weeks.

        Comment


        • #5
          It's not fixed in 1.5.1
          still does not work

          i have a Spring application using JDBC templates.

          gary

          Comment


          • #6
            Originally posted by jtravis View Post
            We have discovered why JDBC is not showing up for some people. You will have this issue if AspectJ overweaving is enabled. Please check out your tc-server's bin/setenv.sh to ensure that overweaving is not enabled. (or take a look at your STS Server configuration)
            STS Server Configuration might be reading this from some file. Even if you make a change it does not save it. also, which tc-server/bin dir are you talking about ? there is one setenv.sh under insight/bin directory without the stuff you have mentioned.

            Comment

            Working...
            X