Announcement Announcement Module
Collapse
No announcement yet.
hyperic Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • hyperic

    Hi,

    Is this a good place to ask questions about hyperic? I've tried the hyperic forums, at
    http://forums.hyperic.com/jiveforums/ but they don't seem to have hyperic developers reading them, and looking for a developer mailing list, or forums.

    First question is, has anyone got Hyperic working with Jboss 5.1.0.GA, or when will it be supported?

    Regards
    Glen Ogilvie

  • #2
    Open and edit jboss-plugin.jar/etc/hq-plugin.xml file and add in

    <server name="JBoss"
    version="5.1"
    include="5.0">
    </server>

    Then put this jar file to plugin folder in server and agent.

    Comment


    • #3
      Development is underway to move Hyperic HQ to use the Spring framework.After that work is done,the application will be quite portable and can run in any Java application server.

      Comment


      • #4
        awesome khaishen

        Comment


        • #5
          Aditional to edit jboss-plugin.jar/etc/hq-plugin.xml

          Originally posted by khaishen View Post
          Open and edit jboss-plugin.jar/etc/hq-plugin.xml file and add in

          <server name="JBoss"
          version="5.1"
          include="5.0">
          </server>

          Then put this jar file to plugin folder in server and agent.
          I have it working now.

          try to edit the archive hq-plugin.xml as commented for hyperic to recognize the version 5.1 and use the jar command for reinsert it in the jar, or when yo change the configuration in hyperic, it will give the message that the jar is corrupt.

          copy the following libs in hq-agent/bundles/agent-4.5.1/pdk/lib:
          jboss-client
          jboss-common-core
          jboss-javaee
          jboss-logging-jdk
          jboss-logging-log4j
          jboss-logging-spi
          jboss-plugin
          jboss-remoting
          jboss-security-spi
          jboss-serialization
          jbosssx-as-client
          jbosssx-client
          jboss-transaction
          jnpclient
          those libraries are in the jboss 5.1 installer and one of this you find in internet I don't remember which, cause it's not in the installer. The problem is that before jboss-common had into the libraries required, since the version 5.1 it has just references to those libraries, after yo do that, restart the agent. Review the agent.log, review the port of ajp by default 1099.

          excuse me for my English
          greetings.

          Comment


          • #6
            Hyperic is proud of its vibrant, growing community - it's a testament to the value of our software and the demand for what we provide. The Hyperic community consists of core developers and empowered system administrators who share their experiences and expertise. Find out what people are doing with our systems monitoring and management and SIGAR products.

            Comment


            • #7
              Almost there...

              Which jboss-plugin goes into the lib folder? Is it from jboss? the plugin jar from the plugins folder?

              Originally posted by diegomon View Post
              I have it working now.

              try to edit the archive hq-plugin.xml as commented for hyperic to recognize the version 5.1 and use the jar command for reinsert it in the jar, or when yo change the configuration in hyperic, it will give the message that the jar is corrupt.

              copy the following libs in hq-agent/bundles/agent-4.5.1/pdk/lib:
              jboss-client
              jboss-common-core
              jboss-javaee
              jboss-logging-jdk
              jboss-logging-log4j
              jboss-logging-spi
              jboss-plugin
              jboss-remoting
              jboss-security-spi
              jboss-serialization
              jbosssx-as-client
              jbosssx-client
              jboss-transaction
              jnpclient
              those libraries are in the jboss 5.1 installer and one of this you find in internet I don't remember which, cause it's not in the installer. The problem is that before jboss-common had into the libraries required, since the version 5.1 it has just references to those libraries, after yo do that, restart the agent. Review the agent.log, review the port of ajp by default 1099.

              excuse me for my English
              greetings.

              Comment

              Working...
              X