Announcement Announcement Module
Collapse
No announcement yet.
jmx behind firewall on tomcat driving me crazy Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • jmx behind firewall on tomcat driving me crazy

    Hi,

    I have tried what i believe is everything to allow me to connect via jmx to my web app. It is running behind a firewall.

    Here is my connector:
    <bean id="serverConnector"
    class="org.springframework.jmx.support.ConnectorSe rverFactoryBean">
    <property name="objectName" value="connector:name=rmi"/>
    <property name="serviceUrl"
    value="service:jmx:rmi://mail.top-eeee.com/jndi/rmi://localhost:8335/server"/>
    </bean>

    I get this error when connecting:
    FINER: [javax.management.remote.rmi.RMIConnector: jmxServiceURL=service:jmx:rmi://mail.top-eeee.com:8100/jndi/rmi://mail.top-eeee.com:8335/server] failed to connect: java.rmi.ConnectException: Connection refused to host: 127.0.0.1; nested exception is:
    java.net.ConnectException: Connection refused

    If I change the serviceUrl to:
    service:jmx:rmi://mail.top-eeee.com/jndi/rmi://mail.top-eeee.com:8335/server

    Then I get this error:
    FINER: [javax.management.remote.rmi.RMIConnector: jmxServiceURL=service:jmx:rmi://mail.eeee.com:8100/jndi/rmi://mail.top-eeee.com:8335/server] Failed to retrieve RMIServer stub: javax.naming.NameNotFoundException: server

    Any ideas?

    Thanks,
    Craig

  • #2
    I am doing this on linux, could it be anything to do with my hostname...it appears to me that after connecting to the rmi registry, it is being told to use ip 127.0.0.1...which is bad, i am trying to connect from a remote computer

    Comment


    • #3
      it was a hostname problem. i now have hostname -i returning the ip address of the firewall, and it seems to work.

      Comment

      Working...
      X